CVE-2023-5217 Google Chromium libvpx Heap Buffer Overflow
A remote attacker can execute arbitrary code via heap corruption in libvpx by tricking a user into visiting a crafted HTML page.
- Exploited in the wild
- Since 2 Oct 2023
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2023-5217?
CVE-2023-5217 is a high-severity memory corruption vulnerability in Apple Ipados, published on 28 Sep 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Heap buffer overflow in vp8 encoding in libvpx in Google Chrome prior to 117.0.5938.132 and libvpx 1.13.1 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page. (Chromium security severity: High)
Weakness: CWE-787
Which versions are affected by CVE-2023-5217?
10 open source packages ship an affected version, including electron. It affects 11 products.
| Package | Affected | Fixed in |
|---|---|---|
electron npm | All versions | 22.3.25 |
electron npm | All versions | 22.3.25 |
electron npm | From 24.0.0 | 24.8.5 |
electron npm | From 24.0.0 | 24.8.5 |
electron npm | From 25.0.0 | 25.8.4 |
electron npm | From 25.0.0 | 25.8.4 |
4 more packages
electron npm | From 26.0.0 | 26.2.4 |
electron npm | From 26.0.0 | 26.2.4 |
electron npm | From 27.0.0-alpha.1 | 27.0.0-beta.8 |
electron npm | From 27.0.0-alpha.1 | 27.0.0-beta.8 |
Linux distribution packages (30)
MozillaFirefox SUSE:Enterprise Storage 7.1 | All versions | 115.3.1-150200.152.111.1 |
libvpx SUSE:Enterprise Storage 7.1 | All versions | 1.6.1-150000.6.11.1 |
MozillaFirefox SUSE:Linux Enterprise High Performance Computing 15 SP1-LTSS | All versions | 115.3.1-150000.150.110.1 |
libvpx SUSE:Linux Enterprise High Performance Computing 15 SP1-LTSS | All versions | 1.6.1-150000.6.11.1 |
MozillaFirefox SUSE:Linux Enterprise High Performance Computing 15 SP2-LTSS | All versions | 115.3.1-150200.152.111.1 |
libvpx SUSE:Linux Enterprise High Performance Computing 15 SP2-LTSS | All versions | 1.6.1-150000.6.11.1 |
MozillaFirefox SUSE:Linux Enterprise High Performance Computing 15 SP3-ESPOS | All versions | 115.3.1-150200.152.111.1 |
libvpx SUSE:Linux Enterprise High Performance Computing 15 SP3-ESPOS | All versions | 1.6.1-150000.6.11.1 |
MozillaFirefox SUSE:Linux Enterprise High Performance Computing 15 SP3-LTSS | All versions | 115.3.1-150200.152.111.1 |
libvpx SUSE:Linux Enterprise High Performance Computing 15 SP3-LTSS | All versions | 1.6.1-150000.6.11.1 |
libvpx SUSE:Linux Enterprise Module for Basesystem 15 SP4 | All versions | 1.11.0-150400.3.3.1 |
libvpx SUSE:Linux Enterprise Module for Basesystem 15 SP5 | All versions | 1.11.0-150400.3.3.1 |
MozillaFirefox SUSE:Linux Enterprise Module for Desktop Applications 15 SP4 | All versions | 115.3.1-150200.152.111.1 |
libvpx SUSE:Linux Enterprise Module for Desktop Applications 15 SP4 | All versions | 1.6.1-150000.6.11.1 |
MozillaFirefox SUSE:Linux Enterprise Module for Desktop Applications 15 SP5 | All versions | 115.3.1-150200.152.111.1 |
libvpx SUSE:Linux Enterprise Module for Desktop Applications 15 SP5 | All versions | 1.6.1-150000.6.11.1 |
libvpx SUSE:Linux Enterprise Module for Package Hub 15 SP4 | All versions | 1.11.0-150400.3.3.1 |
libvpx SUSE:Linux Enterprise Module for Package Hub 15 SP5 | All versions | 1.11.0-150400.3.3.1 |
MozillaFirefox SUSE:Linux Enterprise Server 12 SP5 | All versions | 115.3.1-112.185.1 |
libvpx SUSE:Linux Enterprise Server 12 SP5 | All versions | 1.3.0-3.12.1 |
MozillaFirefox SUSE:Linux Enterprise Server 15 SP1-LTSS | All versions | 115.3.1-150000.150.110.1 |
libvpx SUSE:Linux Enterprise Server 15 SP1-LTSS | All versions | 1.6.1-150000.6.11.1 |
MozillaFirefox SUSE:Linux Enterprise Server 15 SP2-LTSS | All versions | 115.3.1-150200.152.111.1 |
libvpx SUSE:Linux Enterprise Server 15 SP2-LTSS | All versions | 1.6.1-150000.6.11.1 |
MozillaFirefox SUSE:Linux Enterprise Server 15 SP3-LTSS | All versions | 115.3.1-150200.152.111.1 |
libvpx SUSE:Linux Enterprise Server 15 SP3-LTSS | All versions | 1.6.1-150000.6.11.1 |
MozillaFirefox SUSE:Linux Enterprise Server for SAP Applications 12 SP5 | All versions | 115.3.1-112.185.1 |
libvpx SUSE:Linux Enterprise Server for SAP Applications 12 SP5 | All versions | 1.3.0-3.12.1 |
MozillaFirefox SUSE:Linux Enterprise Server for SAP Applications 15 SP1 | All versions | 115.3.1-150000.150.110.1 |
libvpx SUSE:Linux Enterprise Server for SAP Applications 15 SP1 | All versions | 1.6.1-150000.6.11.1 |
Products include Apple Ipados, Apple Iphone Os, Debian Debian Linux, Fedoraproject Fedora, Google Chrome, Microsoft Edge and 5 more.
How do I fix CVE-2023-5217?
Upgrade electron to a fixed version for your release line: 22.3.25, 24.8.5, 25.8.4 or 26.2.4. US federal agencies must fix it by 23 Oct 2023.
Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.
Is CVE-2023-5217 being exploited?
Yes. Attackers have exploited CVE-2023-5217 in the wild since at least 2 Oct 2023.
Public exploit code: 3 proofs of concept on GitHub.
Other vulnerabilities in Apple Ipados
- CVE-2025-43300 Apple iOS, iPadOS, and macOS Out-of-Bounds Write
- CVE-2025-24201 Apple Multiple Products WebKit Out-of-Bounds Write
- CVE-2025-24085 Apple Multiple Products Use-After-Free
- CVE-2025-31200 Apple Multiple Products Memory Corruption
- CVE-2025-31201 Apple Multiple Products Arbitrary Read and Write
Sources
Also known as DEBIAN-CVE-2023-5217, DLA-3591-1, DSA-5509-1, DSA-5510-1, GHSA-qqvq-6xgj-jw8g, JLSEC-2026-375 and 14 more.