{"answers":{"affected":"3 open source packages ship an affected version, including paddlepaddle and PaddlePaddle. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-52310 exists.","fix":"Upgrade paddlepaddle to 2.6.0 or later.","what":"CVE-2023-52310 is a critical command injection vulnerability in PaddlePaddle, published on 3 Jan 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-52310 and fix it if it is affected.\n\nWhat it is: CVE-2023-52310 is a critical command injection vulnerability in PaddlePaddle, published on 3 Jan 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-52310 exists.\n\nAffected packages and fixed versions:\n- paddlepaddle (PyPI): affected all versions; fixed in 2.6.0\n- paddlepaddle (PyPI): affected all versions; fixed in 2.6.0\n- PaddlePaddle (PyPI): affected all versions; fixed in 2.6.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-52310/ (Markdown: https://insights.sbomify.com/CVE-2023-52310/index.md)","id":"CVE-2023-52310","markdown":"https://insights.sbomify.com/CVE-2023-52310/index.md","name":"CVE-2023-52310","record":{"aliases":["GHSA-j5h9-9r39-43q5","PYSEC-2024-142"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"PaddlePaddle ML library","requires_auth":"none","summary":"Attackers can execute arbitrary OS commands via the get_online_pass_interval function in PaddlePaddle, requiring an upgrade to mitigate.","user_interaction":"required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Baidu","cpe":[{"product":"paddlepaddle","vendor":"paddlepaddle"}],"cvss":{"score":9.6,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"}],"description":"PaddlePaddle before 2.6.0 has a command injection in get_online_pass_interval. This resulted in the ability to execute arbitrary commands on the operating system.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Command injection in get_online_pass_interval","id":"CVE-2023-52310","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"command_injection","year":"2023"},"n_packages":3,"n_references":1,"next":{"headline":"Command injection in _wget_download","id":"CVE-2023-52311"},"packages":[{"ecosystem":"PyPI","fixed":["2.6.0"],"introduced":["0"],"last_affected":[],"package":"PaddlePaddle","purl":null,"source":"GHSA-j5h9-9r39-43q5"},{"ecosystem":"PyPI","fixed":["2.6.0"],"introduced":["0"],"last_affected":[],"package":"paddlepaddle","purl":"pkg:pypi/paddlepaddle","source":"GHSA-j5h9-9r39-43q5"},{"ecosystem":"PyPI","fixed":["2.6.0"],"introduced":["0"],"last_affected":[],"package":"paddlepaddle","purl":"pkg:pypi/paddlepaddle","source":"PYSEC-2024-142"}],"prev":{"headline":"Heap buffer overflow in paddle.repeat_interleave","id":"CVE-2023-52309"},"products":["PaddlePaddle"],"published":"2024-01-03","related":[{"cvss_score":10,"headline":"PaddlePaddle vulnerable to Code Injection","id":"CVE-2022-46742","kev_date_added":null,"published":"2022-12-07"},{"cvss_score":9.8,"headline":"PaddlePaddle vulnerable to code injection via winstr","id":"CVE-2022-45908","kev_date_added":null,"published":"2022-11-26"},{"cvss_score":9.6,"headline":"Command injection in _wget_download","id":"CVE-2023-52311","kev_date_added":null,"published":"2024-01-03"},{"cvss_score":9.6,"headline":"Command injection in convert_shape_compare","id":"CVE-2023-52314","kev_date_added":null,"published":"2024-01-03"},{"cvss_score":9.6,"headline":"Command injection in fs.py","id":"CVE-2023-38673","kev_date_added":null,"published":"2023-07-26"},{"cvss_score":9.4,"headline":"PaddlePaddle vulnerable to remote code execution","id":"CVE-2024-0917","kev_date_added":null,"published":"2024-03-07"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-04-17","vendors":["PaddlePaddle"]},"summary":"Attackers can execute arbitrary OS commands via the get_online_pass_interval function in PaddlePaddle, requiring an upgrade to mitigate.","url":"https://insights.sbomify.com/CVE-2023-52310/"}