{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-52722 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2023-52722 is a medium-severity vulnerability in Artifex Ghostscript, published on 27 Apr 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-52722 and fix it if it is affected.\n\nWhat it is: CVE-2023-52722 is a medium-severity vulnerability in Artifex Ghostscript, published on 27 Apr 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2023-52722 in the wild and no public exploit code.\n\nAffected product: Artifex Ghostscript. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-52722/ (Markdown: https://insights.sbomify.com/CVE-2023-52722/index.md)","id":"CVE-2023-52722","markdown":"https://insights.sbomify.com/CVE-2023-52722/index.md","name":"CVE-2023-52722","record":{"aliases":["ALPINE-CVE-2023-52722","BELL-CVE-2023-52722","CLSA-2026-1786720807","CLSA-2026-1788335582","DEBIAN-CVE-2023-52722","GHSA-5473-w6gq-5r5g","MGASA-2024-0180","SUSE-SU-2024:1568-1","SUSE-SU-2024:1590-1","SUSE-SU-2024:1590-2","UBUNTU-CVE-2023-52722"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"adjacent_or_local","non_default_config":true,"product_category":"Ghostscript library","requires_auth":"none","summary":"Attackers can bypass Ghostscript's SAFER mode restrictions by using non-standard eexec seeds, potentially enabling further exploitation.","user_interaction":"required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"ghostscript","vendor":"artifex"}],"cvss":{"score":5.5,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N","version":"3.1"},"cwes":[],"description":"An issue was discovered in Artifex Ghostscript before 10.03.1. psi/zmisc1.c, when SAFER mode is used, allows eexec seeds other than the Type 1 standard.","ecosystems":["SUSE:Linux Enterprise Module for Basesystem 15 SP5","SUSE:Linux Enterprise Module for Basesystem 15 SP6","SUSE:Linux Enterprise Server 12 SP5","SUSE:Linux Enterprise Server for SAP Applications 12 SP5","SUSE:Linux Enterprise Software Development Kit 12 SP5","openSUSE:Leap 15.5","openSUSE:Leap 15.6"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Security feature bypass in n/a","id":"CVE-2023-52722","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"artifex:ghostscript","products":["artifex:ghostscript"],"type":"security_feature_bypass","year":"2023"},"n_packages":7,"n_references":2,"next":{"headline":"Hardcoded credentials in n/a","id":"CVE-2023-52723"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Module for Basesystem 15 SP5","fixed":["9.52-150000.188.1"],"introduced":["0"],"last_affected":[],"package":"ghostscript","purl":"pkg:rpm/suse/ghostscript\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Basesystem%2015%20SP5","source":"SUSE-SU-2024:1590-1"},{"ecosystem":"SUSE:Linux Enterprise Module for Basesystem 15 SP6","fixed":["9.52-150000.188.1"],"introduced":["0"],"last_affected":[],"package":"ghostscript","purl":"pkg:rpm/suse/ghostscript\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Basesystem%2015%20SP6","source":"SUSE-SU-2024:1590-2"},{"ecosystem":"SUSE:Linux Enterprise Server 12 SP5","fixed":["9.52-23.74.1"],"introduced":["0"],"last_affected":[],"package":"ghostscript","purl":"pkg:rpm/suse/ghostscript\u0026distro=SUSE%20Linux%20Enterprise%20Server%2012%20SP5","source":"SUSE-SU-2024:1568-1"},{"ecosystem":"SUSE:Linux Enterprise Server for SAP Applications 12 SP5","fixed":["9.52-23.74.1"],"introduced":["0"],"last_affected":[],"package":"ghostscript","purl":"pkg:rpm/suse/ghostscript\u0026distro=SUSE%20Linux%20Enterprise%20Server%20for%20SAP%20Applications%2012%20SP5","source":"SUSE-SU-2024:1568-1"},{"ecosystem":"SUSE:Linux Enterprise Software Development Kit 12 SP5","fixed":["9.52-23.74.1"],"introduced":["0"],"last_affected":[],"package":"ghostscript","purl":"pkg:rpm/suse/ghostscript\u0026distro=SUSE%20Linux%20Enterprise%20Software%20Development%20Kit%2012%20SP5","source":"SUSE-SU-2024:1568-1"},{"ecosystem":"openSUSE:Leap 15.5","fixed":["9.52-150000.188.1"],"introduced":["0"],"last_affected":[],"package":"ghostscript","purl":"pkg:rpm/opensuse/ghostscript\u0026distro=openSUSE%20Leap%2015.5","source":"SUSE-SU-2024:1590-1"},{"ecosystem":"openSUSE:Leap 15.6","fixed":["9.52-150000.188.1"],"introduced":["0"],"last_affected":[],"package":"ghostscript","purl":"pkg:rpm/opensuse/ghostscript\u0026distro=openSUSE%20Leap%2015.6","source":"SUSE-SU-2024:1590-2"}],"prev":{"headline":"Missing authorization in EMUI","id":"CVE-2023-52721"},"products":["n/a"],"published":"2024-04-27","related":[{"cvss_score":7.8,"headline":"Artifex Ghostscript Type Confusion","id":"CVE-2017-8291","kev_date_added":"2022-05-24","published":"2017-04-27"},{"cvss_score":9.9,"headline":"Command injection in ghostscript","id":"CVE-2021-3781","kev_date_added":null,"published":"2022-02-16"},{"cvss_score":9.8,"headline":"Memory corruption in n/a","id":"CVE-2025-27831","kev_date_added":null,"published":"2025-03-25"},{"cvss_score":9.8,"headline":"Memory corruption in n/a","id":"CVE-2025-27832","kev_date_added":null,"published":"2025-03-25"},{"cvss_score":9.8,"headline":"Memory corruption in n/a","id":"CVE-2025-27836","kev_date_added":null,"published":"2025-03-25"},{"cvss_score":9.8,"headline":"An issue was discovered in Artifex Ghostscript before 10.05.0.","id":"CVE-2025-27837","kev_date_added":null,"published":"2025-03-25"},{"cvss_score":9.8,"headline":"Use after free in n/a","id":"CVE-2020-36773","kev_date_added":null,"published":"2024-02-04"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-12-04","vendors":["n/a"]},"summary":"Attackers can bypass Ghostscript's SAFER mode restrictions by using non-standard eexec seeds, potentially enabling further exploitation.","url":"https://insights.sbomify.com/CVE-2023-52722/"}