# CVE-2023-52892: Name confusion in x509 Subject Alternative Name fields

> Attackers can bypass TLS certificate host verification by exploiting regex injection in Subject Alternative Name fields, allowing man-in-the-middle attacks.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Jun 2024
- **Updated:** 21 Aug 2024
- **Also known as:** DEBIAN-CVE-2023-52892, GHSA-ff7q-6vwh-v9m4, UBUNTU-CVE-2023-52892

## What is CVE-2023-52892?

CVE-2023-52892 is a high-severity vulnerability in n/a, published on 27 Jun 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In phpseclib before 1.0.22, 2.x before 2.0.46, and 3.x before 3.0.33, some characters in Subject Alternative Name fields in TLS certificates are incorrectly allowed to have a special meaning in regular expressions (such as a + wildcard), leading to name confusion in X.509 certificate host verification.

Weakness: CWE-436 (Interpretation Conflict)

## Which versions are affected by CVE-2023-52892?

6 open source packages ship an affected version, including phpseclib/phpseclib. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `phpseclib/phpseclib` | Packagist | All versions | 1.0.22 |
| `phpseclib/phpseclib` | Packagist | All versions | 1.0.22 |
| `phpseclib/phpseclib` | Packagist | From 2.0.0 | 2.0.46 |
| `phpseclib/phpseclib` | Packagist | From 2.0.0 | 2.0.46 |
| `phpseclib/phpseclib` | Packagist | From 3.0.0 | 3.0.33 |
| `phpseclib/phpseclib` | Packagist | From 3.0.0 | 3.0.33 |

Products: Phpseclib Phpseclib.

## How do I fix CVE-2023-52892?

Upgrade phpseclib/phpseclib to a fixed version for your release line: 1.0.22, 2.0.46 or 3.0.33.

## Is CVE-2023-52892 being exploited?

There is no known exploitation of CVE-2023-52892 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2026-32935](https://insights.sbomify.com/CVE-2026-32935/): phpseclib's AES-CBC unpadding susceptible to padding oracle timing attack (high 8.2)
- [CVE-2023-49316](https://insights.sbomify.com/CVE-2023-49316/): Phpseclib needs guardrails on large binaryfield integers (high 7.5)
- [CVE-2023-27560](https://insights.sbomify.com/CVE-2023-27560/): phpseclib Infinite Loop vulnerability (high 7.5)
- [CVE-2026-55599](https://insights.sbomify.com/CVE-2026-55599/): phpseclib: X.509 certificate validation sends attacker-controlled outbound requests (server-side request forgery) via Authority Information Access (medium 5.8)
- [CVE-2026-40194](https://insights.sbomify.com/CVE-2026-40194/): phpseclib has a variable-time HMAC comparison in SSH2::get_binary_packet() using != instead of hash_equals() (low 3.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-52892 and fix it if it is affected.

What it is: CVE-2023-52892 is a high-severity vulnerability in n/a, published on 27 Jun 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-52892 in the wild and no public exploit code.

Affected packages and fixed versions:
- phpseclib/phpseclib (Packagist): affected all versions; fixed in 1.0.22
- phpseclib/phpseclib (Packagist): affected all versions; fixed in 1.0.22
- phpseclib/phpseclib (Packagist): affected from 2.0.0; fixed in 2.0.46
- phpseclib/phpseclib (Packagist): affected from 2.0.0; fixed in 2.0.46
- phpseclib/phpseclib (Packagist): affected from 3.0.0; fixed in 3.0.33
- phpseclib/phpseclib (Packagist): affected from 3.0.0; fixed in 3.0.33

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-52892/ (Markdown: https://insights.sbomify.com/CVE-2023-52892/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-52892
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-52892
- OSV: https://osv.dev/vulnerability/CVE-2023-52892

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-52892/
Summaries are generated and may contain mistakes; the official description above is the record.
