CVE-2023-52968 Null dereference in MariaDB
A null pointer dereference in MariaDB Server allows attackers to cause a crash and denial of service via crafted queries.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-52968?
CVE-2023-52968 is a medium-severity vulnerability in MariaDB, published on 8 Mar 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
MariaDB Server 10.4 before 10.4.33, 10.5 before 10.5.24, 10.6 before 10.6.17, 10.7 through 10.11 before 10.11.7, 11.0 before 11.0.5, and 11.1 before 11.1.4 calls fix_fields_if_needed under mysql_derived_prepare when derived is not yet prepared, leading to a find_field_in_table crash.
Weakness: CWE-696
Which versions are affected by CVE-2023-52968?
3 open source packages ship an affected version, including mariadb, mariadb-min and mysql-client.
| Package | Affected | Fixed in |
|---|---|---|
mariadb Bitnami | From 10.4.0 | 10.4.33, 10.5.24, 10.6.17, 10.11.7, 11.0.5, 11.1.4 |
mariadb-min Bitnami | From 10.4.0 | 10.4.33, 10.5.24, 10.6.17, 10.11.7, 11.0.5, 11.1.4 |
mysql-client Bitnami | From 10.4.0 | 10.4.33, 10.5.24, 10.6.17, 10.11.7, 11.0.5, 11.1.4 |
How do I fix CVE-2023-52968?
Upgrade mariadb to a fixed version for your release line: 10.4.33, 10.5.24, 10.6.17 or 10.11.7.
Is CVE-2023-52968 being exploited?
There is no known exploitation of CVE-2023-52968 in the wild and no public exploit code.
Sources
Also known as BELL-CVE-2023-52968, BIT-mariadb-2023-52968, BIT-mariadb-min-2023-52968, BIT-mysql-client-2023-52968, DEBIAN-CVE-2023-52968, GHSA-7c2c-wp2q-q5vx and 1 more.