{"answers":{"affected":"3 open source packages ship an affected version, including mariadb, mariadb-min and mysql-client.","exploited":"There is no known exploitation of CVE-2023-52968 in the wild and no public exploit code.","fix":"Upgrade mariadb to a fixed version for your release line: 10.4.33, 10.5.24, 10.6.17 or 10.11.7.","what":"CVE-2023-52968 is a medium-severity vulnerability in MariaDB, published on 8 Mar 2025. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-52968 and fix it if it is affected.\n\nWhat it is: CVE-2023-52968 is a medium-severity vulnerability in MariaDB, published on 8 Mar 2025. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-52968 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- mariadb (Bitnami): affected from 10.4.0; fixed in 10.4.33, 10.5.24, 10.6.17, 10.11.7, 11.0.5, 11.1.4\n- mariadb-min (Bitnami): affected from 10.4.0; fixed in 10.4.33, 10.5.24, 10.6.17, 10.11.7, 11.0.5, 11.1.4\n- mysql-client (Bitnami): affected from 10.4.0; fixed in 10.4.33, 10.5.24, 10.6.17, 10.11.7, 11.0.5, 11.1.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-52968/ (Markdown: https://insights.sbomify.com/CVE-2023-52968/index.md)","id":"CVE-2023-52968","markdown":"https://insights.sbomify.com/CVE-2023-52968/index.md","name":"CVE-2023-52968","record":{"aliases":["BELL-CVE-2023-52968","BIT-mariadb-2023-52968","BIT-mariadb-min-2023-52968","BIT-mysql-client-2023-52968","DEBIAN-CVE-2023-52968","GHSA-7c2c-wp2q-q5vx","UBUNTU-CVE-2023-52968"],"analysis":{"component_type":"database","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"MariaDB Server","requires_auth":"high_privilege","summary":"A null pointer dereference in MariaDB Server allows attackers to cause a crash and denial of service via crafted queries.","user_interaction":"not_required","vuln_class":"null_dereference"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[],"cvss":{"score":4.9,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-696","name":"Incorrect Behavior Order"}],"description":"MariaDB Server 10.4 before 10.4.33, 10.5 before 10.5.24, 10.6 before 10.6.17, 10.7 through 10.11 before 10.11.7, 11.0 before 11.0.5, and 11.1 before 11.1.4 calls fix_fields_if_needed under mysql_derived_prepare when derived is not yet prepared, leading to a find_field_in_table crash.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Null dereference in MariaDB","id":"CVE-2023-52968","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"null_dereference","year":"2023"},"n_packages":3,"n_references":1,"next":{"headline":"Denial of service in MariaDB","id":"CVE-2023-52969"},"packages":[{"ecosystem":"Bitnami","fixed":["10.4.33","10.5.24","10.6.17","10.11.7","11.0.5","11.1.4"],"introduced":["10.4.0","10.5.0","10.6.0","10.7.0","11.0.0","11.1.0"],"last_affected":[],"package":"mariadb","purl":"pkg:bitnami/mariadb","source":"BIT-mariadb-2023-52968"},{"ecosystem":"Bitnami","fixed":["10.4.33","10.5.24","10.6.17","10.11.7","11.0.5","11.1.4"],"introduced":["10.4.0","10.5.0","10.6.0","10.7.0","11.0.0","11.1.0"],"last_affected":[],"package":"mariadb-min","purl":"pkg:bitnami/mariadb-min","source":"BIT-mariadb-min-2023-52968"},{"ecosystem":"Bitnami","fixed":["10.4.33","10.5.24","10.6.17","10.11.7","11.0.5","11.1.4"],"introduced":["10.4.0","10.5.0","10.6.0","10.7.0","11.0.0","11.1.0"],"last_affected":[],"package":"mysql-client","purl":"pkg:bitnami/mysql-client","source":"BIT-mysql-client-2023-52968"}],"prev":{"headline":"Auth bypass in EMUI","id":"CVE-2023-52955"},"products":["MariaDB"],"published":"2025-03-08","related":[],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-03-10","vendors":["MariaDB"]},"summary":"A null pointer dereference in MariaDB Server allows attackers to cause a crash and denial of service via crafted queries.","url":"https://insights.sbomify.com/CVE-2023-52968/"}