CVE-2023-52969 Denial of service in MariaDB
An attacker can cause MariaDB Server to crash, resulting in a denial of service for database users.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-52969?
CVE-2023-52969 is a medium-severity denial of service vulnerability in MariaDB, published on 8 Mar 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
MariaDB Server 10.4 through 10.5.*, 10.6 through 10.6.*, 10.7 through 10.11.*, and 11.0 through 11.0.* can sometimes crash with an empty backtrace log. This may be related to make_aggr_tables_info and optimize_stage2.
Weakness: CWE-1038
Which versions are affected by CVE-2023-52969?
3 open source packages ship an affected version, including mariadb, mariadb-min and mysql-client.
| Package | Affected | Fixed in |
|---|---|---|
mariadb Bitnami | All versions | 10.5.29, 10.6.22, 10.11.12, 11.4.6, 11.8.2 |
mariadb-min Bitnami | All versions | 10.5.29, 10.6.22, 10.11.12, 11.4.6, 11.8.2 |
mysql-client Bitnami | All versions | 10.5.29, 10.6.22, 10.11.12, 11.4.6, 11.8.2 |
How do I fix CVE-2023-52969?
Upgrade mariadb to a fixed version for your release line: 10.5.29, 10.6.22, 10.11.12 or 11.4.6.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2023-52969 being exploited?
There is no known exploitation of CVE-2023-52969 in the wild and no public exploit code.
Sources
Also known as AZL-58073, AZL-58082, BELL-CVE-2023-52969, BIT-mariadb-2023-52969, BIT-mariadb-min-2023-52969, BIT-mysql-client-2023-52969 and 14 more.