# CVE-2023-52970: Denial of service in MariaDB

> A flaw in MariaDB Server causes a crash during specific query processing, leading to a denial of service for database administrators.

- **Severity:** Medium 4.9 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Mar 2025
- **Updated:** 3 Nov 2025
- **Also known as:** AZL-58070, AZL-58074, BELL-CVE-2023-52970, BIT-mariadb-2023-52970, BIT-mariadb-min-2023-52970, BIT-mysql-client-2023-52970, DEBIAN-CVE-2023-52970, ECHO-605d-2ba1-6ba6, GHSA-g8xg-6v3j-w97f, MINI-4467-2v33-3j44, MINI-48hr-5j6m-j9v8, MINI-56pw-p3j7-v2h8, MINI-c464-rxh8-g3mp, MINI-f6r9-vx79-vggq, MINI-mvf7-qx9f-6rhg, MINI-wfqf-hgp8-5qvg, UBUNTU-CVE-2023-52970

## What is CVE-2023-52970?

CVE-2023-52970 is a medium-severity denial of service vulnerability in MariaDB, published on 8 Mar 2025. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

MariaDB Server 10.4 through 10.5.*, 10.6 through 10.6.*, 10.7 through 10.11.*, 11.0 through 11.0.*, and 11.1 through 11.4.* crashes in Item_direct_view_ref::derived_field_transformer_for_where.

Weakness: CWE-1038 (Insecure Automated Optimizations)

## Which versions are affected by CVE-2023-52970?

3 open source packages ship an affected version, including mariadb, mariadb-min and mysql-client.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mariadb` | Bitnami | All versions | 10.5.29, 10.6.22, 10.11.12, 11.4.6, 11.8.2 |
| `mariadb-min` | Bitnami | All versions | 10.5.29, 10.6.22, 10.11.12, 11.4.6, 11.8.2 |
| `mysql-client` | Bitnami | All versions | 10.5.29, 10.6.22, 10.11.12, 11.4.6, 11.8.2 |

## How do I fix CVE-2023-52970?

Upgrade mariadb to a fixed version for your release line: 10.5.29, 10.6.22, 10.11.12 or 11.4.6.

## Is CVE-2023-52970 being exploited?

There is no known exploitation of CVE-2023-52970 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-52970 and fix it if it is affected.

What it is: CVE-2023-52970 is a medium-severity denial of service vulnerability in MariaDB, published on 8 Mar 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-52970 in the wild and no public exploit code.

Affected packages and fixed versions:
- mariadb (Bitnami): affected all versions; fixed in 10.5.29, 10.6.22, 10.11.12, 11.4.6, 11.8.2
- mariadb-min (Bitnami): affected all versions; fixed in 10.5.29, 10.6.22, 10.11.12, 11.4.6, 11.8.2
- mysql-client (Bitnami): affected all versions; fixed in 10.5.29, 10.6.22, 10.11.12, 11.4.6, 11.8.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-52970/ (Markdown: https://insights.sbomify.com/CVE-2023-52970/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-52970
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-52970
- OSV: https://osv.dev/vulnerability/CVE-2023-52970

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-52970/
Summaries are generated and may contain mistakes; the official description above is the record.
