CVE-2023-52971 Denial of service in MariaDB
A flaw in MariaDB Server causes a crash during query plan optimization, leading to a denial of service for database administrators.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-52971?
CVE-2023-52971 is a medium-severity denial of service vulnerability in MariaDB, published on 8 Mar 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
MariaDB Server 10.10 through 10.11.* and 11.0 through 11.4.* crashes in JOIN::fix_all_splittings_in_plan.
Weakness: CWE-1038
Which versions are affected by CVE-2023-52971?
3 open source packages ship an affected version, including mariadb, mariadb-min and mysql-client.
| Package | Affected | Fixed in |
|---|---|---|
mariadb Bitnami | From 10.10.0 | 10.11.12, 11.4.6, 11.8.2 |
mariadb-min Bitnami | From 10.10.0 | 10.11.12, 11.4.6, 11.8.2 |
mysql-client Bitnami | From 10.10.0 | 10.11.12, 11.4.6, 11.8.2 |
How do I fix CVE-2023-52971?
Upgrade mariadb to a fixed version for your release line: 10.11.12, 11.4.6 or 11.8.2.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2023-52971 being exploited?
There is no known exploitation of CVE-2023-52971 in the wild and no public exploit code.
Sources
Also known as AZL-58079, BELL-CVE-2023-52971, BIT-mariadb-2023-52971, BIT-mariadb-min-2023-52971, BIT-mysql-client-2023-52971, DEBIAN-CVE-2023-52971 and 8 more.