# CVE-2023-52971: Denial of service in MariaDB

> A flaw in MariaDB Server causes a crash during query plan optimization, leading to a denial of service for database administrators.

- **Severity:** Medium 4.9 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Mar 2025
- **Updated:** 12 May 2025
- **Also known as:** AZL-58079, BELL-CVE-2023-52971, BIT-mariadb-2023-52971, BIT-mariadb-min-2023-52971, BIT-mysql-client-2023-52971, DEBIAN-CVE-2023-52971, ECHO-5ef4-b229-41d7, GHSA-j57w-cc2h-3w6w, MINI-j99h-q3c8-7q5f, MINI-jgjq-2v22-4jxh, MINI-jvf8-qqxx-m6xw, MINI-vcg7-wxf8-v9p8, MINI-wpf8-r7x2-6mm3, UBUNTU-CVE-2023-52971

## What is CVE-2023-52971?

CVE-2023-52971 is a medium-severity denial of service vulnerability in MariaDB, published on 8 Mar 2025. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

MariaDB Server 10.10 through 10.11.* and 11.0 through 11.4.* crashes in JOIN::fix_all_splittings_in_plan.

Weakness: CWE-1038 (Insecure Automated Optimizations)

## Which versions are affected by CVE-2023-52971?

3 open source packages ship an affected version, including mariadb, mariadb-min and mysql-client.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mariadb` | Bitnami | From 10.10.0 | 10.11.12, 11.4.6, 11.8.2 |
| `mariadb-min` | Bitnami | From 10.10.0 | 10.11.12, 11.4.6, 11.8.2 |
| `mysql-client` | Bitnami | From 10.10.0 | 10.11.12, 11.4.6, 11.8.2 |

## How do I fix CVE-2023-52971?

Upgrade mariadb to a fixed version for your release line: 10.11.12, 11.4.6 or 11.8.2.

## Is CVE-2023-52971 being exploited?

There is no known exploitation of CVE-2023-52971 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-52971 and fix it if it is affected.

What it is: CVE-2023-52971 is a medium-severity denial of service vulnerability in MariaDB, published on 8 Mar 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-52971 in the wild and no public exploit code.

Affected packages and fixed versions:
- mariadb (Bitnami): affected from 10.10.0; fixed in 10.11.12, 11.4.6, 11.8.2
- mariadb-min (Bitnami): affected from 10.10.0; fixed in 10.11.12, 11.4.6, 11.8.2
- mysql-client (Bitnami): affected from 10.10.0; fixed in 10.11.12, 11.4.6, 11.8.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-52971/ (Markdown: https://insights.sbomify.com/CVE-2023-52971/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-52971
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-52971
- OSV: https://osv.dev/vulnerability/CVE-2023-52971

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-52971/
Summaries are generated and may contain mistakes; the official description above is the record.
