# CVE-2023-53156: transpose: Buffer overflow due to integer overflow

> An integer overflow in the transpose crate allows attackers to cause a denial of service via crafted input dimensions.

- **Severity:** Medium 4.5 (`CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:C/C:N/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Jul 2025
- **Updated:** 28 Jul 2025
- **Also known as:** DEBIAN-CVE-2023-53156, GHSA-5gmm-6m36-r7jh, RUSTSEC-2023-0080, UBUNTU-CVE-2023-53156

## What is CVE-2023-53156?

CVE-2023-53156 is a medium-severity vulnerability in ejmahler transpose, published on 27 Jul 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

The transpose crate before 0.2.3 for Rust allows an integer overflow via input_width and input_height arguments.

Weakness: CWE-190 (Integer Overflow or Wraparound)

## Which versions are affected by CVE-2023-53156?

3 open source packages ship an affected version, including transpose. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `transpose` | crates.io | From 0.0.0-0 | 0.2.3 |
| `transpose` | crates.io | From 0.1.0 | 0.2.3 |
| `transpose` | crates.io | From 0.1.0 | 0.2.3 |

Products: Ejmahler Transpose.

## How do I fix CVE-2023-53156?

Upgrade transpose to 0.2.3 or later.

## Is CVE-2023-53156 being exploited?

There is no known exploitation of CVE-2023-53156 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-53156 and fix it if it is affected.

What it is: CVE-2023-53156 is a medium-severity vulnerability in ejmahler transpose, published on 27 Jul 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-53156 in the wild and no public exploit code.

Affected packages and fixed versions:
- transpose (crates.io): affected from 0.0.0-0; fixed in 0.2.3
- transpose (crates.io): affected from 0.1.0; fixed in 0.2.3
- transpose (crates.io): affected from 0.1.0; fixed in 0.2.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-53156/ (Markdown: https://insights.sbomify.com/CVE-2023-53156/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-53156
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-53156
- OSV: https://osv.dev/vulnerability/CVE-2023-53156

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-53156/
Summaries are generated and may contain mistakes; the official description above is the record.
