# CVE-2023-53158: gix-transport code execution vulnerability


- **Severity:** Medium 4.1 (`CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 28 Jul 2025
- **Updated:** 28 Jul 2025
- **Also known as:** AZL-66020, GHSA-rrjw-j4m2-mf34, RUSTSEC-2023-0064, UBUNTU-CVE-2023-53158

## What is CVE-2023-53158?

CVE-2023-53158 is a medium-severity vulnerability in GitoxideLabs gix-transport, published on 28 Jul 2025. 

### Official description

The gix-transport crate before 0.36.1 for Rust allows command execution via the "gix clone 'ssh://-oProxyCommand=open$IFS" substring. NOTE: this was discovered before CVE-2024-32884, a similar vulnerability (involving a username field) that is more difficult to exploit.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2023-53158?

3 open source packages ship an affected version, including gix-transport.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gix-transport` | crates.io | All versions | 0.36.1 |
| `gix-transport` | crates.io | All versions | 0.36.1 |
| `gix-transport` | crates.io | From 0.0.0-0 | 0.36.1 |

## How do I fix CVE-2023-53158?

Upgrade gix-transport to 0.36.1 or later.

## Is CVE-2023-53158 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-53158 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-53158 and fix it if it is affected.

What it is: CVE-2023-53158 is a medium-severity vulnerability in GitoxideLabs gix-transport, published on 28 Jul 2025. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-53158 exists.

Affected packages and fixed versions:
- gix-transport (crates.io): affected all versions; fixed in 0.36.1
- gix-transport (crates.io): affected all versions; fixed in 0.36.1
- gix-transport (crates.io): affected from 0.0.0-0; fixed in 0.36.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-53158/ (Markdown: https://insights.sbomify.com/CVE-2023-53158/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-53158
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-53158
- OSV: https://osv.dev/vulnerability/CVE-2023-53158

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-53158/
Summaries are generated and may contain mistakes; the official description above is the record.
