# CVE-2023-53159: `openssl` `X509VerifyParamRef::set_host` buffer over-read

> An out-of-bounds read in the Rust openssl crate allows attackers to cause denial of service or disclose memory contents via crafted input.

- **Severity:** Medium 4.5 (`CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:C/C:L/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Jul 2025
- **Updated:** 28 Jul 2025
- **Also known as:** DEBIAN-CVE-2023-53159, GHSA-xcf7-rvmh-g6q4, RUSTSEC-2023-0044, UBUNTU-CVE-2023-53159

## What is CVE-2023-53159?

CVE-2023-53159 is a medium-severity memory corruption vulnerability in sfackler openssl, published on 28 Jul 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

The openssl crate before 0.10.55 for Rust allows an out-of-bounds read via an empty string to X509VerifyParamRef::set_host.

Weakness: CWE-126 (Buffer Over-read)

## Which versions are affected by CVE-2023-53159?

3 open source packages ship an affected version, including openssl. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `openssl` | crates.io | From 0.0.0-0 | 0.10.55 |
| `openssl` | crates.io | From 0.10.0 | 0.10.55 |
| `openssl` | crates.io | From 0.10.0 | 0.10.55 |

Products: Sfackler Openssl.

## How do I fix CVE-2023-53159?

Upgrade openssl to 0.10.55 or later.

## Is CVE-2023-53159 being exploited?

There is no known exploitation of CVE-2023-53159 in the wild and no public exploit code.

## Other vulnerabilities in sfackler openssl

- [CVE-2026-45784](https://insights.sbomify.com/CVE-2026-45784/): rust-openssl: Potential out-of-bounds write in `CipherCtxRef::cipher_update_inplace` for AES-KW-PAD ciphers (medium 5.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-53159 and fix it if it is affected.

What it is: CVE-2023-53159 is a medium-severity memory corruption vulnerability in sfackler openssl, published on 28 Jul 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-53159 in the wild and no public exploit code.

Affected packages and fixed versions:
- openssl (crates.io): affected from 0.0.0-0; fixed in 0.10.55
- openssl (crates.io): affected from 0.10.0; fixed in 0.10.55
- openssl (crates.io): affected from 0.10.0; fixed in 0.10.55

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-53159/ (Markdown: https://insights.sbomify.com/CVE-2023-53159/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-53159
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-53159
- OSV: https://osv.dev/vulnerability/CVE-2023-53159

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-53159/
Summaries are generated and may contain mistakes; the official description above is the record.
