CVE-2023-53160 sequoia-openpgp vulnerable to out-of-bounds array access leading to panic
An out-of-bounds array access in the sequoia-openpgp Rust library allows attackers to cause a panic and denial of service.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-53160?
CVE-2023-53160 is a low-severity memory corruption vulnerability in sequoia-pgp sequoia, published on 28 Jul 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
The sequoia-openpgp crate before 1.16.0 for Rust allows out-of-bounds array access and a panic.
Weakness: CWE-125
Which versions are affected by CVE-2023-53160?
7 open source packages ship an affected version, including sequoia-openpgp. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
sequoia-openpgp crates.io | All versions | 1.1.1 |
sequoia-openpgp crates.io | All versions | 1.1.1 |
sequoia-openpgp crates.io | From 0.0.0-0 | 1.1.1, 1.8.1, 1.16.0 |
sequoia-openpgp crates.io | From 1.2.0 | 1.8.1 |
sequoia-openpgp crates.io | From 1.2.0 | 1.8.1 |
sequoia-openpgp crates.io | From 1.9.0 | 1.16.0 |
1 more packages
sequoia-openpgp crates.io | From 1.9.0 | 1.16.0 |
Products include Sequoia-Pgp Sequoia-Openpgp.
How do I fix CVE-2023-53160?
Upgrade sequoia-openpgp to a fixed version for your release line: 1.1.1, 1.8.1 or 1.16.0.
Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.
Is CVE-2023-53160 being exploited?
There is no known exploitation of CVE-2023-53160 in the wild and no public exploit code.
Other vulnerabilities in sequoia-pgp sequoia
Sources
Also known as DEBIAN-CVE-2023-53160, GHSA-25mx-8f3v-8wh7, RUSTSEC-2023-0038, UBUNTU-CVE-2023-53160.