CVE-2023-53161 buffered-reader vulnerable to out-of-bounds array access leading to panic
An out-of-bounds array access in the Rust buffered-reader crate allows attackers to cause a panic and denial of service.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-53161?
CVE-2023-53161 is a low-severity memory corruption vulnerability in sequoia-pgp buffered-reader, published on 28 Jul 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
The buffered-reader crate before 1.1.5 for Rust allows out-of-bounds array access and a panic.
Weakness: CWE-125
Which versions are affected by CVE-2023-53161?
5 open source packages ship an affected version, including buffered-reader. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
buffered-reader crates.io | All versions | 1.0.2 |
buffered-reader crates.io | All versions | 1.0.2 |
buffered-reader crates.io | From 0.0.0-0 | 1.0.2, 1.1.5, 1.2.0 |
buffered-reader crates.io | From 1.1.0 | 1.1.5 |
buffered-reader crates.io | From 1.1.0 | 1.1.5 |
Products include Sequoia-Pgp Buffered-Reader.
How do I fix CVE-2023-53161?
Upgrade buffered-reader to a fixed version for your release line: 1.0.2, 1.1.5 or 1.2.0.
Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.
Is CVE-2023-53161 being exploited?
There is no known exploitation of CVE-2023-53161 in the wild and no public exploit code.
Sources
Also known as DEBIAN-CVE-2023-53161, GHSA-29mf-62xx-28jq, RUSTSEC-2023-0039, UBUNTU-CVE-2023-53161.