{"answers":{"affected":"5 open source packages ship an affected version, including buffered-reader. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-53161 in the wild and no public exploit code.","fix":"Upgrade buffered-reader to a fixed version for your release line: 1.0.2, 1.1.5 or 1.2.0.","what":"CVE-2023-53161 is a low-severity memory corruption vulnerability in sequoia-pgp buffered-reader, published on 28 Jul 2025. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-53161 and fix it if it is affected.\n\nWhat it is: CVE-2023-53161 is a low-severity memory corruption vulnerability in sequoia-pgp buffered-reader, published on 28 Jul 2025. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-53161 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- buffered-reader (crates.io): affected all versions; fixed in 1.0.2\n- buffered-reader (crates.io): affected all versions; fixed in 1.0.2\n- buffered-reader (crates.io): affected from 0.0.0-0; fixed in 1.0.2, 1.1.5, 1.2.0\n- buffered-reader (crates.io): affected from 1.1.0; fixed in 1.1.5\n- buffered-reader (crates.io): affected from 1.1.0; fixed in 1.1.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-53161/ (Markdown: https://insights.sbomify.com/CVE-2023-53161/index.md)","id":"CVE-2023-53161","markdown":"https://insights.sbomify.com/CVE-2023-53161/index.md","name":"CVE-2023-53161","record":{"aliases":["DEBIAN-CVE-2023-53161","GHSA-29mf-62xx-28jq","RUSTSEC-2023-0039","UBUNTU-CVE-2023-53161"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Rust buffered-reader crate","requires_auth":"none","summary":"An out-of-bounds array access in the Rust buffered-reader crate allows attackers to cause a panic and denial of service.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"buffered-reader","vendor":"sequoia-pgp"}],"cvss":{"score":2.9,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-125","name":"Out-of-bounds Read"}],"description":"The buffered-reader crate before 1.1.5 for Rust allows out-of-bounds array access and a panic.","ecosystems":["crates.io"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"buffered-reader vulnerable to out-of-bounds array access leading to panic","id":"CVE-2023-53161","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"memory_corruption","year":"2023"},"n_packages":5,"n_references":6,"next":{"headline":"fs/ntfs3: don't hold ni_lock when calling truncate_setsize()","id":"CVE-2023-53163"},"packages":[{"ecosystem":"crates.io","fixed":["1.0.2"],"introduced":["0"],"last_affected":[],"package":"buffered-reader","purl":null,"source":"GHSA-29mf-62xx-28jq"},{"ecosystem":"crates.io","fixed":["1.0.2"],"introduced":["0"],"last_affected":[],"package":"buffered-reader","purl":"pkg:cargo/buffered-reader","source":"GHSA-29mf-62xx-28jq"},{"ecosystem":"crates.io","fixed":["1.0.2","1.1.5","1.2.0"],"introduced":["0.0.0-0","1.1.0","1.2.0"],"last_affected":[],"package":"buffered-reader","purl":"pkg:cargo/buffered-reader","source":"RUSTSEC-2023-0039"},{"ecosystem":"crates.io","fixed":["1.1.5"],"introduced":["1.1.0"],"last_affected":[],"package":"buffered-reader","purl":null,"source":"GHSA-29mf-62xx-28jq"},{"ecosystem":"crates.io","fixed":["1.1.5"],"introduced":["1.1.0"],"last_affected":[],"package":"buffered-reader","purl":"pkg:cargo/buffered-reader","source":"GHSA-29mf-62xx-28jq"}],"prev":{"headline":"sequoia-openpgp vulnerable to out-of-bounds array access leading to panic","id":"CVE-2023-53160"},"products":["buffered-reader"],"published":"2025-07-28","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"open","licence":"CC0 1.0","name":"RustSec","prefix":"RUSTSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-07-28","vendors":["sequoia-pgp"]},"summary":"An out-of-bounds array access in the Rust buffered-reader crate allows attackers to cause a panic and denial of service.","url":"https://insights.sbomify.com/CVE-2023-53161/"}