# CVE-2023-53161: buffered-reader vulnerable to out-of-bounds array access leading to panic

> An out-of-bounds array access in the Rust buffered-reader crate allows attackers to cause a panic and denial of service.

- **Severity:** Low 2.9 (`CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Jul 2025
- **Updated:** 28 Jul 2025
- **Also known as:** DEBIAN-CVE-2023-53161, GHSA-29mf-62xx-28jq, RUSTSEC-2023-0039, UBUNTU-CVE-2023-53161

## What is CVE-2023-53161?

CVE-2023-53161 is a low-severity memory corruption vulnerability in sequoia-pgp buffered-reader, published on 28 Jul 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

The buffered-reader crate before 1.1.5 for Rust allows out-of-bounds array access and a panic.

Weakness: CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2023-53161?

5 open source packages ship an affected version, including buffered-reader. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `buffered-reader` | crates.io | All versions | 1.0.2 |
| `buffered-reader` | crates.io | All versions | 1.0.2 |
| `buffered-reader` | crates.io | From 0.0.0-0 | 1.0.2, 1.1.5, 1.2.0 |
| `buffered-reader` | crates.io | From 1.1.0 | 1.1.5 |
| `buffered-reader` | crates.io | From 1.1.0 | 1.1.5 |

Products: Sequoia-Pgp Buffered-Reader.

## How do I fix CVE-2023-53161?

Upgrade buffered-reader to a fixed version for your release line: 1.0.2, 1.1.5 or 1.2.0.

## Is CVE-2023-53161 being exploited?

There is no known exploitation of CVE-2023-53161 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-53161 and fix it if it is affected.

What it is: CVE-2023-53161 is a low-severity memory corruption vulnerability in sequoia-pgp buffered-reader, published on 28 Jul 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-53161 in the wild and no public exploit code.

Affected packages and fixed versions:
- buffered-reader (crates.io): affected all versions; fixed in 1.0.2
- buffered-reader (crates.io): affected all versions; fixed in 1.0.2
- buffered-reader (crates.io): affected from 0.0.0-0; fixed in 1.0.2, 1.1.5, 1.2.0
- buffered-reader (crates.io): affected from 1.1.0; fixed in 1.1.5
- buffered-reader (crates.io): affected from 1.1.0; fixed in 1.1.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-53161/ (Markdown: https://insights.sbomify.com/CVE-2023-53161/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-53161
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-53161
- OSV: https://osv.dev/vulnerability/CVE-2023-53161

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-53161/
Summaries are generated and may contain mistakes; the official description above is the record.
