{"answers":{"affected":"It affects 2 products.","exploited":"There is no known exploitation of CVE-2023-5346 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2023-5346 is a high-severity memory corruption vulnerability in Fedoraproject Fedora, published on 5 Oct 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-5346 and fix it if it is affected.\n\nWhat it is: CVE-2023-5346 is a high-severity memory corruption vulnerability in Fedoraproject Fedora, published on 5 Oct 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2023-5346 in the wild and no public exploit code.\n\nAffected product: Fedoraproject Fedora. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-5346/ (Markdown: https://insights.sbomify.com/CVE-2023-5346/index.md)","id":"CVE-2023-5346","markdown":"https://insights.sbomify.com/CVE-2023-5346/index.md","name":"CVE-2023-5346","record":{"aliases":["DEBIAN-CVE-2023-5346","DSA-5515-1","GHSA-4vx7-4j56-j894","openSUSE-SU-2023:0292-1","openSUSE-SU-2024:13292-1","openSUSE-SU-2024:13303-1"],"analysis":{"component_type":"browser","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Google Chrome","requires_auth":"none","summary":"A type confusion vulnerability in Chrome's V8 engine allows remote attackers to execute arbitrary code via a crafted HTML page.","user_interaction":"required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Chrome","cpe":[{"product":"fedora","vendor":"fedoraproject"},{"product":"chrome","vendor":"google"}],"cvss":{"score":8.8,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-843","name":"Access of Resource Using Incompatible Type"}],"description":"Type confusion in V8 in Google Chrome prior to 117.0.5938.149 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page. (Chromium security severity: High)","ecosystems":["SUSE:Package Hub 15 SP5","openSUSE:Leap 15.5","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Memory corruption in Chrome","id":"CVE-2023-5346","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"fedoraproject:fedora","products":["fedoraproject:fedora","google:chrome"],"type":"memory_corruption","year":"2023"},"n_packages":4,"n_references":6,"next":{"headline":"Unauthenticated Firmware Upgrade","id":"CVE-2023-5347"},"packages":[{"ecosystem":"SUSE:Package Hub 15 SP5","fixed":["117.0.5938.149-bp155.2.43.1"],"introduced":["0"],"last_affected":[],"package":"chromium","purl":"pkg:rpm/suse/chromium\u0026distro=SUSE%20Package%20Hub%2015%20SP5","source":"openSUSE-SU-2023:0292-1"},{"ecosystem":"openSUSE:Leap 15.5","fixed":["117.0.5938.149-bp155.2.43.1"],"introduced":["0"],"last_affected":[],"package":"chromium","purl":"pkg:rpm/opensuse/chromium\u0026distro=openSUSE%20Leap%2015.5","source":"openSUSE-SU-2023:0292-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["117.0.5938.149-1.1"],"introduced":["0"],"last_affected":[],"package":"chromium","purl":"pkg:rpm/opensuse/chromium\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:13292-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["117.0.5938.149-1.1"],"introduced":["0"],"last_affected":[],"package":"chromium","purl":"pkg:rpm/opensuse/chromium\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:13303-1"}],"prev":{"headline":"Use-after-free in Linux kernel's fs/smb/client component","id":"CVE-2023-5345"},"products":["Chrome"],"published":"2023-10-05","related":[{"cvss_score":9.8,"headline":"PHP-CGI OS Command Injection","id":"CVE-2024-4577","kev_date_added":"2024-06-12","published":"2024-06-09"},{"cvss_score":9.8,"headline":"Grafana Authentication Bypass","id":"CVE-2021-39226","kev_date_added":"2022-08-25","published":"2021-10-05"},{"cvss_score":9.8,"headline":"VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow","id":"CVE-2019-5544","kev_date_added":"2021-11-03","published":"2019-12-06"},{"cvss_score":9.6,"headline":"Google Chromium V8 Type Confusion","id":"CVE-2024-4947","kev_date_added":"2024-05-20","published":"2024-05-15"},{"cvss_score":9.6,"headline":"Google Chromium Visuals Use-After-Free","id":"CVE-2024-4671","kev_date_added":"2024-05-13","published":"2024-05-09"},{"cvss_score":9.6,"headline":"Google Chromium Mojo Insufficient Data Validation","id":"CVE-2022-3075","kev_date_added":"2022-09-08","published":"2022-09-26"},{"cvss_score":9.6,"headline":"Google Chromium Indexed DB API Use-After-Free","id":"CVE-2021-30633","kev_date_added":"2021-11-03","published":"2021-10-08"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-05-01","vendors":["Google"]},"summary":"A type confusion vulnerability in Chrome's V8 engine allows remote attackers to execute arbitrary code via a crafted HTML page.","url":"https://insights.sbomify.com/CVE-2023-5346/"}