CVE-2023-5356 Incorrect Authorization in GitLab

High 7.3 Published Updated

Attackers can abuse Slack/Mattermost integrations to execute slash commands as another user due to incorrect authorization checks in GitLab.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2023-5356?

CVE-2023-5356 is a high-severity missing authorization vulnerability in Gitlab Gitlab, published on 12 Jan 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

Official description

Incorrect authorization checks in GitLab CE/EE from all versions starting from 8.13 before 16.5.6, all versions starting from 16.6 before 16.6.4, all versions starting from 16.7 before 16.7.2, allows a user to abuse slack/mattermost integrations to execute slash commands as another user.

Weakness: CWE-863

Which versions are affected by CVE-2023-5356?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 8.13.016.5.6, 16.6.4, 16.7.2

Products include Gitlab Gitlab.

How do I fix CVE-2023-5356?

Upgrade gitlab to a fixed version for your release line: 16.5.6, 16.6.4 or 16.7.2.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2023-5356 being exploited?

There is no known exploitation of CVE-2023-5356 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2023-5356, GHSA-x7v8-7cpc-hv73, UBUNTU-CVE-2023-5356.

Is CVE-2023-5356 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free