# CVE-2023-54356: Kyverno before 1.9.5 Sweet32 Medium Strength Cipher Suites

> Kyverno supports insecure 3DES cipher suites, allowing attackers to recover plaintext via Sweet32 attacks on long-lived TLS connections.

- **Severity:** Critical 9.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Sep 2026
- **Updated:** 8 Oct 2026
- **Also known as:** BIT-kyverno-2023-54356, CLEANSTART-2026-MH57563, GHSA-hgv6-w7r3-w4qw, GHSA-x85p-7rrx-px32, GO-2023-1804

## What is CVE-2023-54356?

CVE-2023-54356 is a critical vulnerability in kyverno, published on 1 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Kyverno versions 1.9.4 and earlier support insecure 3DES cipher suites (TLS_ECDHE_RSA_WITH_3DES_EDE_CBC_SHA and TLS_RSA_WITH_3DES_EDE_CBC_SHA) on their TLS endpoints. These 64-bit block ciphers are vulnerable to the Sweet32 attack (CVE-2016-2183), which, over very long-lived TLS connections carrying large volumes of traffic, could allow an attacker to recover small amounts of plaintext. The issue is fixed in Kyverno 1.9.5 and 1.10.0.

Weakness: CWE-326 (Inadequate Encryption Strength)

## Which versions are affected by CVE-2023-54356?

4 open source packages ship an affected version, including github.com/kyverno/kyverno and kyverno.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/kyverno/kyverno` | Go | All versions | 1.9.5 |
| `github.com/kyverno/kyverno` | Go | All versions | 1.9.5 |
| `github.com/kyverno/kyverno` | Go | All versions | 1.9.5 |
| `kyverno` | Bitnami | All versions | 1.9.5 |

## How do I fix CVE-2023-54356?

Upgrade github.com/kyverno/kyverno to 1.9.5 or later.

## Is CVE-2023-54356 being exploited?

There is no known exploitation of CVE-2023-54356 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-54356 and fix it if it is affected.

What it is: CVE-2023-54356 is a critical vulnerability in kyverno, published on 1 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-54356 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/kyverno/kyverno (Go): affected all versions; fixed in 1.9.5
- github.com/kyverno/kyverno (Go): affected all versions; fixed in 1.9.5
- github.com/kyverno/kyverno (Go): affected all versions; fixed in 1.9.5
- kyverno (Bitnami): affected all versions; fixed in 1.9.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-54356/ (Markdown: https://insights.sbomify.com/CVE-2023-54356/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-54356
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-54356
- OSV: https://osv.dev/vulnerability/CVE-2023-54356

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-54356/
Summaries are generated and may contain mistakes; the official description above is the record.
