# CVE-2023-54366: SurrealDB before 1.0.1 Insecure Default Table Permissions

> SurrealDB's insecure default table permissions allow attackers to read and modify data without explicit authorization.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Jul 2026
- **Updated:** 28 Jul 2026
- **Also known as:** GHSA-x5fr-7hhj-34j3, PYSEC-2026-3718

## What is CVE-2023-54366?

CVE-2023-54366 is a high-severity vulnerability in Surrealdb Surrealdb, published on 18 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

SurrealDB before 1.0.1 sets default table permissions to FULL instead of NONE, allowing SELECT, CREATE, UPDATE, and DELETE operations on tables without explicit permissions. Attackers with database access or unauthenticated users on publicly exposed instances can perform unrestricted operations on unprotected tables within their authorization scope.

Weakness: CWE-276 (Incorrect Default Permissions)

## Which versions are affected by CVE-2023-54366?

3 open source packages ship an affected version, including surrealdb. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `surrealdb` | PyPI | All versions | 1.0.1 |
| `surrealdb` | crates.io | All versions | 1.0.1 |
| `surrealdb` | crates.io | All versions | 1.0.1 |

Products: Surrealdb Surrealdb.

## How do I fix CVE-2023-54366?

Upgrade surrealdb to 1.0.1 or later.

## Is CVE-2023-54366 being exploited?

There is no known exploitation of CVE-2023-54366 in the wild and no public exploit code.

## Other vulnerabilities in Surrealdb Surrealdb

- [CVE-2025-71392](https://insights.sbomify.com/CVE-2025-71392/): SurrealDB before 2.2.2 SurrealQL Injection via export (critical 9.4)
- [CVE-2026-63756](https://insights.sbomify.com/CVE-2026-63756/): SurrealDB before 3.1.0 Privilege Escalation via RPC Session Race Condition (critical 9.2)
- [CVE-2026-63747](https://insights.sbomify.com/CVE-2026-63747/): SurrealDB before 3.1.0 Denial of Service via malformed RPC use (high 8.7)
- [CVE-2026-63757](https://insights.sbomify.com/CVE-2026-63757/): SurrealDB before 3.1.0 Session Hijacking via /rpc sessions (high 8.7)
- [CVE-2026-63760](https://insights.sbomify.com/CVE-2026-63760/): SurrealDB before 3.1.0 Denial of Service via JSON Parser (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-54366 and fix it if it is affected.

What it is: CVE-2023-54366 is a high-severity vulnerability in Surrealdb Surrealdb, published on 18 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-54366 in the wild and no public exploit code.

Affected packages and fixed versions:
- surrealdb (PyPI): affected all versions; fixed in 1.0.1
- surrealdb (crates.io): affected all versions; fixed in 1.0.1
- surrealdb (crates.io): affected all versions; fixed in 1.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-54366/ (Markdown: https://insights.sbomify.com/CVE-2023-54366/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-54366
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-54366
- OSV: https://osv.dev/vulnerability/CVE-2023-54366

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-54366/
Summaries are generated and may contain mistakes; the official description above is the record.
