CVE-2023-54390 PocketMine-MP before 5.3.1 Denial of Service via LoginPacket
Attackers can crash the PocketMine-MP server by sending malformed JSON in LoginPacket, requiring an upgrade to patched versions.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2023-54390?
CVE-2023-54390 is a high-severity denial of service vulnerability in pmmp PocketMine-MP, published on 9 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
PocketMine-MP versions before 5.3.1 and 4.23.1 contain a denial of service vulnerability in LoginPacket JSON parsing due to improper null value handling in arrays. Attackers can send malformed JSON with unexpected null elements in LoginPacket to crash the server.
Weakness: CWE-1025
Which versions are affected by CVE-2023-54390?
4 open source packages ship an affected version, including pocketmine/pocketmine-mp.
| Package | Affected | Fixed in |
|---|---|---|
pocketmine/pocketmine-mp Packagist | All versions | 4.23.1 |
pocketmine/pocketmine-mp Packagist | All versions | 4.23.1 |
pocketmine/pocketmine-mp Packagist | From 5.0.0 | 5.3.1 |
pocketmine/pocketmine-mp Packagist | From 5.0.0 | 5.3.1 |
How do I fix CVE-2023-54390?
Upgrade pocketmine/pocketmine-mp to a fixed version for your release line: 4.23.1 or 5.3.1.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2023-54390 being exploited?
There is no known exploitation of CVE-2023-54390 in the wild and no public exploit code.
Sources
Also known as GHSA-92jh-gwch-jq38, GHSA-q3ff-jxcw-jc3j.