{"answers":{"affected":"4 open source packages ship an affected version, including pocketmine/pocketmine-mp.","exploited":"There is no known exploitation of CVE-2023-54390 in the wild and no public exploit code.","fix":"Upgrade pocketmine/pocketmine-mp to a fixed version for your release line: 4.23.1 or 5.3.1.","what":"CVE-2023-54390 is a high-severity denial of service vulnerability in pmmp PocketMine-MP, published on 9 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-54390 and fix it if it is affected.\n\nWhat it is: CVE-2023-54390 is a high-severity denial of service vulnerability in pmmp PocketMine-MP, published on 9 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-54390 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pocketmine/pocketmine-mp (Packagist): affected all versions; fixed in 4.23.1\n- pocketmine/pocketmine-mp (Packagist): affected all versions; fixed in 4.23.1\n- pocketmine/pocketmine-mp (Packagist): affected from 5.0.0; fixed in 5.3.1\n- pocketmine/pocketmine-mp (Packagist): affected from 5.0.0; fixed in 5.3.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-54390/ (Markdown: https://insights.sbomify.com/CVE-2023-54390/index.md)","id":"CVE-2023-54390","markdown":"https://insights.sbomify.com/CVE-2023-54390/index.md","name":"CVE-2023-54390","record":{"aliases":["GHSA-92jh-gwch-jq38","GHSA-q3ff-jxcw-jc3j"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Minecraft server software","requires_auth":"none","summary":"Attackers can crash the PocketMine-MP server by sending malformed JSON in LoginPacket, requiring an upgrade to patched versions.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":8.7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-1025","name":"Comparison Using Wrong Factors"}],"description":"PocketMine-MP versions before 5.3.1 and 4.23.1 contain a denial of service vulnerability in LoginPacket JSON parsing due to improper null value handling in arrays. Attackers can send malformed JSON with unexpected null elements in LoginPacket to crash the server.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"PocketMine-MP before 5.3.1 Denial of Service via LoginPacket","id":"CVE-2023-54390","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"denial_of_service","year":"2023"},"n_packages":4,"n_references":3,"next":{"headline":"Proxmox VE 7.0-8.0 Authentication Bypass via tfa-challenge Parameter","id":"CVE-2023-54391"},"packages":[{"ecosystem":"Packagist","fixed":["4.23.1"],"introduced":["0"],"last_affected":[],"package":"pocketmine/pocketmine-mp","purl":null,"source":"GHSA-92jh-gwch-jq38"},{"ecosystem":"Packagist","fixed":["4.23.1"],"introduced":["0"],"last_affected":[],"package":"pocketmine/pocketmine-mp","purl":"pkg:composer/pocketmine/pocketmine-mp","source":"GHSA-92jh-gwch-jq38"},{"ecosystem":"Packagist","fixed":["5.3.1"],"introduced":["5.0.0"],"last_affected":[],"package":"pocketmine/pocketmine-mp","purl":null,"source":"GHSA-92jh-gwch-jq38"},{"ecosystem":"Packagist","fixed":["5.3.1"],"introduced":["5.0.0"],"last_affected":[],"package":"pocketmine/pocketmine-mp","purl":"pkg:composer/pocketmine/pocketmine-mp","source":"GHSA-92jh-gwch-jq38"}],"prev":{"headline":"Erroneously reserved under wrong year by automation defect; never assigned.","id":"CVE-2023-54389"},"products":["PocketMine-MP"],"published":"2026-09-09","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-08","vendors":["pmmp"]},"summary":"Attackers can crash the PocketMine-MP server by sending malformed JSON in LoginPacket, requiring an upgrade to patched versions.","url":"https://insights.sbomify.com/CVE-2023-54390/"}