# CVE-2023-54390: PocketMine-MP before 5.3.1 Denial of Service via LoginPacket

> Attackers can crash the PocketMine-MP server by sending malformed JSON in LoginPacket, requiring an upgrade to patched versions.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 9 Sep 2026
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-92jh-gwch-jq38, GHSA-q3ff-jxcw-jc3j

## What is CVE-2023-54390?

CVE-2023-54390 is a high-severity denial of service vulnerability in pmmp PocketMine-MP, published on 9 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

PocketMine-MP versions before 5.3.1 and 4.23.1 contain a denial of service vulnerability in LoginPacket JSON parsing due to improper null value handling in arrays. Attackers can send malformed JSON with unexpected null elements in LoginPacket to crash the server.

Weakness: CWE-1025 (Comparison Using Wrong Factors)

## Which versions are affected by CVE-2023-54390?

4 open source packages ship an affected version, including pocketmine/pocketmine-mp.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pocketmine/pocketmine-mp` | Packagist | All versions | 4.23.1 |
| `pocketmine/pocketmine-mp` | Packagist | All versions | 4.23.1 |
| `pocketmine/pocketmine-mp` | Packagist | From 5.0.0 | 5.3.1 |
| `pocketmine/pocketmine-mp` | Packagist | From 5.0.0 | 5.3.1 |

## How do I fix CVE-2023-54390?

Upgrade pocketmine/pocketmine-mp to a fixed version for your release line: 4.23.1 or 5.3.1.

## Is CVE-2023-54390 being exploited?

There is no known exploitation of CVE-2023-54390 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-54390 and fix it if it is affected.

What it is: CVE-2023-54390 is a high-severity denial of service vulnerability in pmmp PocketMine-MP, published on 9 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-54390 in the wild and no public exploit code.

Affected packages and fixed versions:
- pocketmine/pocketmine-mp (Packagist): affected all versions; fixed in 4.23.1
- pocketmine/pocketmine-mp (Packagist): affected all versions; fixed in 4.23.1
- pocketmine/pocketmine-mp (Packagist): affected from 5.0.0; fixed in 5.3.1
- pocketmine/pocketmine-mp (Packagist): affected from 5.0.0; fixed in 5.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-54390/ (Markdown: https://insights.sbomify.com/CVE-2023-54390/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-54390
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-54390
- OSV: https://osv.dev/vulnerability/CVE-2023-54390

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-54390/
Summaries are generated and may contain mistakes; the official description above is the record.
