CVE-2023-54392 PocketMine-MP before 4.22.3 Denial of Service via BlockActorDataPacket
A remote attacker can crash the PocketMine-MP server by sending a malformed BlockActorDataPacket, causing a denial of service.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2023-54392?
CVE-2023-54392 is a high-severity denial of service vulnerability in pmmp PocketMine-MP, published on 9 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
PocketMine-MP versions >= 4.20.0 before 4.22.3 (and before 5.2.1 in the 5.x branch) fail to validate NBT tag types in BlockActorDataPacket. A player can crash the server by sending a packet containing sign NBT data with an incorrect tag type, triggering an unhandled UnexpectedTagTypeException that terminates the server process.
Weakness: CWE-20
Which versions are affected by CVE-2023-54392?
4 open source packages ship an affected version, including pocketmine/pocketmine-mp.
| Package | Affected | Fixed in |
|---|---|---|
pocketmine/pocketmine-mp Packagist | From 4.20.0 | 4.22.3 |
pocketmine/pocketmine-mp Packagist | From 4.20.0 | 4.22.3 |
pocketmine/pocketmine-mp Packagist | From 5.0.0 | 5.2.1 |
pocketmine/pocketmine-mp Packagist | From 5.0.0 | 5.2.1 |
How do I fix CVE-2023-54392?
Upgrade pocketmine/pocketmine-mp to a fixed version for your release line: 4.22.3 or 5.2.1.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2023-54392 being exploited?
There is no known exploitation of CVE-2023-54392 in the wild and no public exploit code.
Sources
Also known as GHSA-7wrv-6h42-w54f, GHSA-j32g-gv5r-qc39.