# CVE-2023-54392: PocketMine-MP before 4.22.3 Denial of Service via BlockActorDataPacket

> A remote attacker can crash the PocketMine-MP server by sending a malformed BlockActorDataPacket, causing a denial of service.

- **Severity:** High 7.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 9 Sep 2026
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-7wrv-6h42-w54f, GHSA-j32g-gv5r-qc39

## What is CVE-2023-54392?

CVE-2023-54392 is a high-severity denial of service vulnerability in pmmp PocketMine-MP, published on 9 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

PocketMine-MP versions >= 4.20.0 before 4.22.3 (and before 5.2.1 in the 5.x branch) fail to validate NBT tag types in BlockActorDataPacket. A player can crash the server by sending a packet containing sign NBT data with an incorrect tag type, triggering an unhandled UnexpectedTagTypeException that terminates the server process.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2023-54392?

4 open source packages ship an affected version, including pocketmine/pocketmine-mp.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pocketmine/pocketmine-mp` | Packagist | From 4.20.0 | 4.22.3 |
| `pocketmine/pocketmine-mp` | Packagist | From 4.20.0 | 4.22.3 |
| `pocketmine/pocketmine-mp` | Packagist | From 5.0.0 | 5.2.1 |
| `pocketmine/pocketmine-mp` | Packagist | From 5.0.0 | 5.2.1 |

## How do I fix CVE-2023-54392?

Upgrade pocketmine/pocketmine-mp to a fixed version for your release line: 4.22.3 or 5.2.1.

## Is CVE-2023-54392 being exploited?

There is no known exploitation of CVE-2023-54392 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-54392 and fix it if it is affected.

What it is: CVE-2023-54392 is a high-severity denial of service vulnerability in pmmp PocketMine-MP, published on 9 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-54392 in the wild and no public exploit code.

Affected packages and fixed versions:
- pocketmine/pocketmine-mp (Packagist): affected from 4.20.0; fixed in 4.22.3
- pocketmine/pocketmine-mp (Packagist): affected from 4.20.0; fixed in 4.22.3
- pocketmine/pocketmine-mp (Packagist): affected from 5.0.0; fixed in 5.2.1
- pocketmine/pocketmine-mp (Packagist): affected from 5.0.0; fixed in 5.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-54392/ (Markdown: https://insights.sbomify.com/CVE-2023-54392/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-54392
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-54392
- OSV: https://osv.dev/vulnerability/CVE-2023-54392

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-54392/
Summaries are generated and may contain mistakes; the official description above is the record.
