CVE-2023-54393 PocketMine-MP before 4.20.5 Denial of Service via LoginPacket

High 8.7 Published Updated
Exploited in the wild
Not known
Fix
None listed

What is CVE-2023-54393?

CVE-2023-54393 is a high-severity vulnerability in pmmp PocketMine-MP, published on 9 Sep 2026.

Official description

PocketMine-MP versions before 4.20.5 contain a denial of service vulnerability in LoginPacket JSON parsing due to improper validation in the JsonMapper dependency. Attackers can send malformed JSON structures in LoginPacket to crash the server.

Weakness: CWE-20

Which versions are affected by CVE-2023-54393?

4 open source packages ship an affected version, including pocketmine/pocketmine-mp.

PackageAffectedFixed in
pocketmine/pocketmine-mp PackagistAll versions4.20.5
pocketmine/pocketmine-mp PackagistAll versions4.20.5
pocketmine/pocketmine-mp PackagistFrom 4.21.04.21.1
pocketmine/pocketmine-mp PackagistFrom 4.21.04.21.1

How do I fix CVE-2023-54393?

Upgrade pocketmine/pocketmine-mp to a fixed version for your release line: 4.20.5 or 4.21.1.

Is CVE-2023-54393 being exploited?

There is no known exploitation of CVE-2023-54393 in the wild and no public exploit code.

Sources

Also known as GHSA-ghgx-426v-hj74, GHSA-pqp3-8rrw-g8vm.

Is CVE-2023-54393 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free