# CVE-2023-54394: PocketMine-MP before 4.18.0-ALPHA2 Bandwidth Amplification via InventoryTransactionPacket

> Unauthenticated attackers can cause bandwidth exhaustion and denial of service by sending excessive inventory transaction packets to PocketMine-MP servers.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 9 Sep 2026
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-42qm-8v8m-m78c, GHSA-52jh-wmr6-rc6r

## What is CVE-2023-54394?

CVE-2023-54394 is a medium-severity denial of service vulnerability in pmmp PocketMine-MP, published on 9 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

PocketMine-MP before 4.18.0-ALPHA2 fails to rate-limit mismatch type InventoryTransactionPacket requests, allowing attackers to trigger excessive inventory synchronization. Attackers can send numerous mismatch transactions to force the server to transmit large amounts of serialized inventory data, consuming significant bandwidth without authentication.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2023-54394?

2 open source packages ship an affected version, including pocketmine/pocketmine-mp.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pocketmine/pocketmine-mp` | Packagist | All versions | 4.18.0-ALPHA2 |
| `pocketmine/pocketmine-mp` | Packagist | All versions | 4.18.0-ALPHA2 |

## How do I fix CVE-2023-54394?

Upgrade pocketmine/pocketmine-mp to 4.18.0-ALPHA2 or later.

## Is CVE-2023-54394 being exploited?

There is no known exploitation of CVE-2023-54394 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-54394 and fix it if it is affected.

What it is: CVE-2023-54394 is a medium-severity denial of service vulnerability in pmmp PocketMine-MP, published on 9 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-54394 in the wild and no public exploit code.

Affected packages and fixed versions:
- pocketmine/pocketmine-mp (Packagist): affected all versions; fixed in 4.18.0-ALPHA2
- pocketmine/pocketmine-mp (Packagist): affected all versions; fixed in 4.18.0-ALPHA2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-54394/ (Markdown: https://insights.sbomify.com/CVE-2023-54394/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-54394
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-54394
- OSV: https://osv.dev/vulnerability/CVE-2023-54394

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-54394/
Summaries are generated and may contain mistakes; the official description above is the record.
