{"answers":{"affected":"2 open source packages ship an affected version, including pocketmine/pocketmine-mp.","exploited":"There is no known exploitation of CVE-2023-54395 in the wild and no public exploit code.","fix":"Upgrade pocketmine/pocketmine-mp to 4.12.5 or later.","what":"CVE-2023-54395 is a medium-severity denial of service vulnerability in pmmp PocketMine-MP, published on 9 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-54395 and fix it if it is affected.\n\nWhat it is: CVE-2023-54395 is a medium-severity denial of service vulnerability in pmmp PocketMine-MP, published on 9 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-54395 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pocketmine/pocketmine-mp (Packagist): affected all versions; fixed in 4.12.5\n- pocketmine/pocketmine-mp (Packagist): affected all versions; fixed in 4.12.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-54395/ (Markdown: https://insights.sbomify.com/CVE-2023-54395/index.md)","id":"CVE-2023-54395","markdown":"https://insights.sbomify.com/CVE-2023-54395/index.md","name":"CVE-2023-54395","record":{"aliases":["GHSA-3vjv-jh7h-xv9f","GHSA-7m9r-rq9j-wmmh"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Minecraft server software","requires_auth":"low_privilege","summary":"Attackers can cause server resource exhaustion and denial of service by sending oversized JSON payloads in modal form response packets.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-407","name":"Inefficient Algorithmic Complexity"}],"description":"PocketMine-MP versions before 4.12.5 contain a denial-of-service vulnerability in ModalFormResponsePacket processing that allows attackers to cause server resource exhaustion by sending large JSON payloads. Attackers can send numerous oversized modal form response packets to consume CPU time and prevent the server from processing legitimate connections.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"PocketMine-MP before 4.12.5 Denial of Service via ModalFormResponsePacket","id":"CVE-2023-54395","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"denial_of_service","year":"2023"},"n_packages":2,"n_references":3,"next":{"headline":"PocketMine-MP before 4.8.1 Server Crash via Banner NBT","id":"CVE-2023-54396"},"packages":[{"ecosystem":"Packagist","fixed":["4.12.5"],"introduced":["0"],"last_affected":[],"package":"pocketmine/pocketmine-mp","purl":null,"source":"GHSA-7m9r-rq9j-wmmh"},{"ecosystem":"Packagist","fixed":["4.12.5"],"introduced":["0"],"last_affected":[],"package":"pocketmine/pocketmine-mp","purl":"pkg:composer/pocketmine/pocketmine-mp","source":"GHSA-7m9r-rq9j-wmmh"}],"prev":{"headline":"PocketMine-MP before 4.18.0-ALPHA2 Bandwidth Amplification via InventoryTransactionPacket","id":"CVE-2023-54394"},"products":["PocketMine-MP"],"published":"2026-09-09","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-08","vendors":["pmmp"]},"summary":"Attackers can cause server resource exhaustion and denial of service by sending oversized JSON payloads in modal form response packets.","url":"https://insights.sbomify.com/CVE-2023-54395/"}