# CVE-2023-54395: PocketMine-MP before 4.12.5 Denial of Service via ModalFormResponsePacket

> Attackers can cause server resource exhaustion and denial of service by sending oversized JSON payloads in modal form response packets.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 9 Sep 2026
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-3vjv-jh7h-xv9f, GHSA-7m9r-rq9j-wmmh

## What is CVE-2023-54395?

CVE-2023-54395 is a medium-severity denial of service vulnerability in pmmp PocketMine-MP, published on 9 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

PocketMine-MP versions before 4.12.5 contain a denial-of-service vulnerability in ModalFormResponsePacket processing that allows attackers to cause server resource exhaustion by sending large JSON payloads. Attackers can send numerous oversized modal form response packets to consume CPU time and prevent the server from processing legitimate connections.

Weakness: CWE-407 (Inefficient Algorithmic Complexity)

## Which versions are affected by CVE-2023-54395?

2 open source packages ship an affected version, including pocketmine/pocketmine-mp.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pocketmine/pocketmine-mp` | Packagist | All versions | 4.12.5 |
| `pocketmine/pocketmine-mp` | Packagist | All versions | 4.12.5 |

## How do I fix CVE-2023-54395?

Upgrade pocketmine/pocketmine-mp to 4.12.5 or later.

## Is CVE-2023-54395 being exploited?

There is no known exploitation of CVE-2023-54395 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-54395 and fix it if it is affected.

What it is: CVE-2023-54395 is a medium-severity denial of service vulnerability in pmmp PocketMine-MP, published on 9 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-54395 in the wild and no public exploit code.

Affected packages and fixed versions:
- pocketmine/pocketmine-mp (Packagist): affected all versions; fixed in 4.12.5
- pocketmine/pocketmine-mp (Packagist): affected all versions; fixed in 4.12.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-54395/ (Markdown: https://insights.sbomify.com/CVE-2023-54395/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-54395
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-54395
- OSV: https://osv.dev/vulnerability/CVE-2023-54395

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-54395/
Summaries are generated and may contain mistakes; the official description above is the record.
