# CVE-2023-54397: Tornado before 6.3.3 HTTP Request Smuggling via Content-Length

> Attackers can smuggle HTTP requests via malformed Content-Length headers in Tornado, bypassing proxy validation when deployed behind specific proxies.

- **Severity:** Critical 9.0 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:L/VI:H/VA:N/SC:L/SI:H/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Sep 2026
- **Updated:** 17 Sep 2026
- **Also known as:** DEBIAN-CVE-2023-54397, GHSA-qppv-j76h-2rpx, GHSA-rhr2-ccgv-xvgx, ROOT-APP-PYPI-GHSA-qppv-j76h-2rpx, UBUNTU-CVE-2023-54397

## What is CVE-2023-54397?

CVE-2023-54397 is a critical vulnerability in tornadoweb tornado, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Tornado before 6.3.3 contains an HTTP request smuggling vulnerability due to improper parsing of Content-Length headers accepting non-standard characters. Attackers can send crafted HTTP requests with these characters to bypass proxy validation and smuggle requests when deployed behind certain proxies.

Weakness: CWE-444 (Inconsistent Interpretation of HTTP Requests)

## Which versions are affected by CVE-2023-54397?

2 open source packages ship an affected version, including tornado.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `tornado` | PyPI | All versions | 6.3.3 |
| `tornado` | PyPI | All versions | 6.3.3 |

## How do I fix CVE-2023-54397?

Upgrade tornado to 6.3.3 or later.

## Is CVE-2023-54397 being exploited?

There is no known exploitation of CVE-2023-54397 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-54397 and fix it if it is affected.

What it is: CVE-2023-54397 is a critical vulnerability in tornadoweb tornado, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-54397 in the wild and no public exploit code.

Affected packages and fixed versions:
- tornado (PyPI): affected all versions; fixed in 6.3.3
- tornado (PyPI): affected all versions; fixed in 6.3.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-54397/ (Markdown: https://insights.sbomify.com/CVE-2023-54397/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-54397
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-54397
- OSV: https://osv.dev/vulnerability/CVE-2023-54397

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-54397/
Summaries are generated and may contain mistakes; the official description above is the record.
