# CVE-2023-5452: Cross-site Scripting (XSS) - Stored in snipe/snipe-it

> Stored Cross-Site Scripting in Snipe-IT allows attackers to inject malicious scripts, potentially leading to session hijacking or data theft.

- **Severity:** Medium 5.5 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 6 Oct 2023
- **Updated:** 19 Sep 2024
- **Also known as:** GHSA-rr5c-69c9-gj9f

## What is CVE-2023-5452?

CVE-2023-5452 is a medium-severity cross-site scripting vulnerability in Snipeitapp Snipe-It, published on 6 Oct 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Cross-site Scripting (XSS) - Stored in GitHub repository snipe/snipe-it prior to v6.2.2.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2023-5452?

2 open source packages ship an affected version, including snipe/snipe-it. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `snipe/snipe-it` | Packagist | All versions | 6.2.2 |
| `snipe/snipe-it` | Packagist | All versions | 6.2.2 |

Products: Snipeitapp Snipe-It.

## How do I fix CVE-2023-5452?

Upgrade snipe/snipe-it to 6.2.2 or later.

## Is CVE-2023-5452 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-5452 exists.

## Other vulnerabilities in Snipeitapp Snipe-It

- [CVE-2025-63601](https://insights.sbomify.com/CVE-2025-63601/): File upload in n/a (critical 9.9)
- [CVE-2026-37709](https://insights.sbomify.com/CVE-2026-37709/): Snipe-IT has insecure permissions in file uploads (critical 9.8)
- [CVE-2026-86738](https://insights.sbomify.com/CVE-2026-86738/): Snipe-IT before 8.7.0 CSS Injection via Custom CSS (critical 9.3)
- [CVE-2026-116199](https://insights.sbomify.com/CVE-2026-116199/): Snipe-IT before 8.6.3 Authentication Bypass via Google SSO Callback (critical 9.2)
- [CVE-2022-1380](https://insights.sbomify.com/CVE-2022-1380/): Stored Cross Site Scripting vulnerability in Item name parameter in snipe/snipe-it (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-5452 and fix it if it is affected.

What it is: CVE-2023-5452 is a medium-severity cross-site scripting vulnerability in Snipeitapp Snipe-It, published on 6 Oct 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-5452 exists.

Affected packages and fixed versions:
- snipe/snipe-it (Packagist): affected all versions; fixed in 6.2.2
- snipe/snipe-it (Packagist): affected all versions; fixed in 6.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-5452/ (Markdown: https://insights.sbomify.com/CVE-2023-5452/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-5452
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-5452
- OSV: https://osv.dev/vulnerability/CVE-2023-5452

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-5452/
Summaries are generated and may contain mistakes; the official description above is the record.
