CVE-2023-5512 Improper Control of Generation of Code ('Code Injection') in GitLab

Medium 4.8 Published Updated

Attackers can execute arbitrary code via crafted file names in GitLab, requiring permissions to upload files.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2023-5512?

CVE-2023-5512 is a medium-severity code injection vulnerability in Gitlab Gitlab, published on 15 Dec 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

An issue has been discovered in GitLab CE/EE affecting all versions from 16.3 before 16.4.4, all versions starting from 16.5 before 16.5.4, all versions starting from 16.6 before 16.6.2. File integrity may be compromised when specific HTML encoding is used for file names leading for incorrect representation in the UI.

Weakness: CWE-94

Which versions are affected by CVE-2023-5512?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 16.3.016.4.4, 16.5.4, 16.6.2

Products include Gitlab Gitlab.

How do I fix CVE-2023-5512?

Upgrade gitlab to a fixed version for your release line: 16.4.4, 16.5.4 or 16.6.2.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2023-5512 being exploited?

There is no known exploitation of CVE-2023-5512 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2023-5512, GHSA-3vp4-9jc4-q799, UBUNTU-CVE-2023-5512.

Is CVE-2023-5512 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free