{"answers":{"affected":"3 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-5541 in the wild and no public exploit code.","fix":"Upgrade moodle/moodle to 4.3.0-rc2 or later.","what":"CVE-2023-5541 is a low-severity cross-site scripting vulnerability in Moodle Moodle, published on 9 Nov 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-5541 and fix it if it is affected.\n\nWhat it is: CVE-2023-5541 is a low-severity cross-site scripting vulnerability in Moodle Moodle, published on 9 Nov 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2023-5541 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- moodle/moodle (Packagist): affected all versions; fixed in 4.3.0-rc2\n- moodle/moodle (Packagist): affected all versions; fixed in 4.3.0-rc2\n- moodle (Bitnami): affected from 3.9.0; fixed in 3.9.24, 3.11.17, 4.0.11, 4.1.6, 4.2.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-5541/ (Markdown: https://insights.sbomify.com/CVE-2023-5541/index.md)","id":"CVE-2023-5541","markdown":"https://insights.sbomify.com/CVE-2023-5541/index.md","name":"CVE-2023-5541","record":{"aliases":["BIT-moodle-2023-5541","GHSA-28gc-4qq5-8q26","UBUNTU-CVE-2023-5541"],"analysis":{"component_type":"web_application","fix_type":"patch","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Moodle LMS","requires_auth":"none","summary":"An attacker can execute arbitrary scripts in a victim's browser by tricking them into importing a malicious CSV grade file in Moodle.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"fedora","cpe":[{"product":"moodle","vendor":"moodle"}],"cvss":{"score":3.3,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"The CSV grade import method contained an XSS risk for users importing the spreadsheet, if it contained unsafe content.","ecosystems":["Bitnami","Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Moodle: xss risk when using csv grade import method","id":"CVE-2023-5541","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"moodle:moodle","products":["moodle:moodle"],"type":"xss","year":"2023"},"n_packages":3,"n_references":3,"next":{"headline":"Moodle: students can view other users in \"only see own membership\" groups","id":"CVE-2023-5542"},"packages":[{"ecosystem":"Bitnami","fixed":["3.9.24","3.11.17","4.0.11","4.1.6","4.2.3"],"introduced":["3.9.0","3.11.0","4.0.0","4.1.0","4.2.0"],"last_affected":[],"package":"moodle","purl":"pkg:bitnami/moodle","source":"BIT-moodle-2023-5541"},{"ecosystem":"Packagist","fixed":["4.3.0-rc2"],"introduced":["0"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-28gc-4qq5-8q26"},{"ecosystem":"Packagist","fixed":["4.3.0-rc2"],"introduced":["0"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-28gc-4qq5-8q26"}],"prev":{"headline":"Moodle: authenticated remote code execution risk in imscp","id":"CVE-2023-5540"},"products":["moodle:moodle"],"published":"2023-11-09","related":[{"cvss_score":10,"headline":"File upload in n/a","id":"CVE-2006-4935","kev_date_added":null,"published":"2006-09-23"},{"cvss_score":10,"headline":"Moodle does not properly validate module instance id","id":"CVE-2006-4936","kev_date_added":null,"published":"2006-09-23"},{"cvss_score":10,"headline":"Unknown \"front page vulnerability with Moodle servers\" for Moodle before 1.3.2 has unknown impact and attack vectors.","id":"CVE-2004-2233","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Cross-site scripting in n/a","id":"CVE-2004-2235","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2004-2236","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Unknown vulnerability in Moodle before 1.3.4 has unknown impact and attack vectors, related to \"strings in Moodle texts.\"","id":"CVE-2004-2237","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Multiple unknown vulnerabilities in Moodle before 1.5.1 have unknown impact and attack vectors.","id":"CVE-2005-2247","kev_date_added":null,"published":"2005-07-12"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-02","vendors":["moodle"]},"summary":"An attacker can execute arbitrary scripts in a victim's browser by tricking them into importing a malicious CSV grade file in Moodle.","url":"https://insights.sbomify.com/CVE-2023-5541/"}