CVE-2023-5561 WordPress < 6.3.2 - Unauthenticated Post Author Email Disclosure
Unauthenticated attackers can disclose email addresses of users with public posts via REST API search flaws in WordPress.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-5561?
CVE-2023-5561 is a medium-severity vulnerability in Wordpress Wordpress, published on 16 Oct 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
WordPress does not properly restrict which user fields are searchable via the REST API, allowing unauthenticated attackers to discern the email addresses of users who have published public posts on an affected website via an Oracle style attack
Which versions are affected by CVE-2023-5561?
2 open source packages ship an affected version, including wordpress and wordpress-multisite. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
wordpress Bitnami | From 4.7.0 | 4.7.27, 4.8.23, 4.9.24, 5.0.20, 5.1.17, 5.2.19, 5.3.16, 5.4.14, 5.5.13, 5.6.12, 5.7.10, 5.8.8, 5.9.8, 6.0.6, 6.1.4, 6.2.3, 6.3.2 |
wordpress-multisite Bitnami | From 4.7.0 | 4.7.27, 4.8.23, 4.9.24, 5.0.20, 5.1.17, 5.2.19, 5.3.16, 5.4.14, 5.5.13, 5.6.12, 5.7.10, 5.8.8, 5.9.8, 6.0.6, 6.1.4, 6.2.3, 6.3.2 |
Products include Wordpress Wordpress.
How do I fix CVE-2023-5561?
Upgrade wordpress to a fixed version for your release line: 4.7.27, 4.8.23, 4.9.24 or 5.0.20.
Is CVE-2023-5561 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-5561 exists.
Public exploit code: 1 Nuclei template and 3 proofs of concept on GitHub.
Other vulnerabilities in Wordpress Wordpress
Sources
Also known as BIT-wordpress-2023-5561, BIT-wordpress-multisite-2023-5561, DEBIAN-CVE-2023-5561, GHSA-x7w6-3cp2-qjcv, UBUNTU-CVE-2023-5561.