# CVE-2023-5561: WordPress < 6.3.2 - Unauthenticated Post Author Email Disclosure

> Unauthenticated attackers can disclose email addresses of users with public posts via REST API search flaws in WordPress.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Oct 2023
- **Updated:** 23 Apr 2025
- **Also known as:** BIT-wordpress-2023-5561, BIT-wordpress-multisite-2023-5561, DEBIAN-CVE-2023-5561, GHSA-x7w6-3cp2-qjcv, UBUNTU-CVE-2023-5561

## What is CVE-2023-5561?

CVE-2023-5561 is a medium-severity vulnerability in Wordpress Wordpress, published on 16 Oct 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

WordPress does not properly restrict which user fields are searchable via the REST API, allowing unauthenticated attackers to discern the email addresses of users who have published public posts on an affected website via an Oracle style attack

## Which versions are affected by CVE-2023-5561?

2 open source packages ship an affected version, including wordpress and wordpress-multisite. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `wordpress` | Bitnami | From 4.7.0 | 4.7.27, 4.8.23, 4.9.24, 5.0.20, 5.1.17, 5.2.19, 5.3.16, 5.4.14, 5.5.13, 5.6.12, 5.7.10, 5.8.8, 5.9.8, 6.0.6, 6.1.4, 6.2.3, 6.3.2 |
| `wordpress-multisite` | Bitnami | From 4.7.0 | 4.7.27, 4.8.23, 4.9.24, 5.0.20, 5.1.17, 5.2.19, 5.3.16, 5.4.14, 5.5.13, 5.6.12, 5.7.10, 5.8.8, 5.9.8, 6.0.6, 6.1.4, 6.2.3, 6.3.2 |

Products: Wordpress Wordpress.

## How do I fix CVE-2023-5561?

Upgrade wordpress to a fixed version for your release line: 4.7.27, 4.8.23, 4.9.24 or 5.0.20.

## Is CVE-2023-5561 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-5561 exists.

Public exploit code:

- WordPress does not properly restrict which user fields are searchable via the REST API, allowing unauthenticated attackers to discern the email addresses of users who have published public posts on an affected website via an Oracle style attack (github_poc): https://github.com/pog007/CVE-2023-5561-PoC
- Updated POC for Unauth Post Author Email Disclosures WordPress CVE-2023-5561 (github_poc): https://github.com/rootxsushant/CVE-2023-5561-POC-Updated
- CVE-2023-5561-PoC (github_poc): https://github.com/dthkhang/CVE-2023-5561-PoC
- WordPress Core - Post Author Email Disclosure (nuclei): http/cves/2023/CVE-2023-5561.yaml

## Other vulnerabilities in Wordpress Wordpress

- [CVE-2026-63030](https://insights.sbomify.com/CVE-2026-63030/): WordPress Core Interpretation Conflict (critical 9.8, exploited in the wild)
- [CVE-2026-87902](https://insights.sbomify.com/CVE-2026-87902/): WordPress Core Remote File Inclusion (high 8.1, exploited in the wild)
- [CVE-2026-60137](https://insights.sbomify.com/CVE-2026-60137/): WordPress Core SQL Injection (medium 5.9, exploited in the wild)
- [CVE-2012-2399](https://insights.sbomify.com/CVE-2012-2399/): Cross-site scripting in n/a (critical 10.0)
- [CVE-2012-2400](https://insights.sbomify.com/CVE-2012-2400/): Other in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-5561 and fix it if it is affected.

What it is: CVE-2023-5561 is a medium-severity vulnerability in Wordpress Wordpress, published on 16 Oct 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-5561 exists.

Affected packages and fixed versions:
- wordpress (Bitnami): affected from 4.7.0; fixed in 4.7.27, 4.8.23, 4.9.24, 5.0.20, 5.1.17, 5.2.19, 5.3.16, 5.4.14, 5.5.13, 5.6.12, 5.7.10, 5.8.8, 5.9.8, 6.0.6, 6.1.4, 6.2.3, 6.3.2
- wordpress-multisite (Bitnami): affected from 4.7.0; fixed in 4.7.27, 4.8.23, 4.9.24, 5.0.20, 5.1.17, 5.2.19, 5.3.16, 5.4.14, 5.5.13, 5.6.12, 5.7.10, 5.8.8, 5.9.8, 6.0.6, 6.1.4, 6.2.3, 6.3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-5561/ (Markdown: https://insights.sbomify.com/CVE-2023-5561/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-5561
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-5561
- OSV: https://osv.dev/vulnerability/CVE-2023-5561

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-5561/
Summaries are generated and may contain mistakes; the official description above is the record.
