# CVE-2023-5564: Cross-site Scripting (XSS) - Stored in froxlor/froxlor

> Stored Cross-Site Scripting in Froxlor allows attackers to inject malicious scripts, potentially leading to session hijacking or code execution.

- **Severity:** Medium 5.2 (`CVSS:3.0/AV:L/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 13 Oct 2023
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-j5hq-6frc-64v3

## What is CVE-2023-5564?

CVE-2023-5564 is a medium-severity cross-site scripting vulnerability in froxlor/froxlor, published on 13 Oct 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Cross-site Scripting (XSS) - Stored in GitHub repository froxlor/froxlor prior to 2.1.0-dev1.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2023-5564?

2 open source packages ship an affected version, including froxlor/froxlor. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `froxlor/froxlor` | Packagist | All versions | 2.1.0-dev1 |
| `froxlor/froxlor` | Packagist | All versions | 2.1.0-dev1 |

Products: Froxlor Froxlor.

## How do I fix CVE-2023-5564?

Upgrade froxlor/froxlor to 2.1.0-dev1 or later.

## Is CVE-2023-5564 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-5564 exists.

## Other vulnerabilities in froxlor/froxlor

- [CVE-2026-41228](https://insights.sbomify.com/CVE-2026-41228/): Froxlor has Local File Inclusion via path traversal in API `def_language` parameter that leads to Remote Code Execution (critical 10.0)
- [CVE-2023-6069](https://insights.sbomify.com/CVE-2023-6069/): Improper Link Resolution Before File Access in froxlor/froxlor (critical 9.9)
- [CVE-2023-0671](https://insights.sbomify.com/CVE-2023-0671/): Code Injection in froxlor/froxlor (critical 9.9)
- [CVE-2023-3173](https://insights.sbomify.com/CVE-2023-3173/): Improper Restriction of Excessive Authentication Attempts in froxlor/froxlor (critical 9.8)
- [CVE-2023-1307](https://insights.sbomify.com/CVE-2023-1307/): Authentication Bypass by Primary Weakness in froxlor/froxlor (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-5564 and fix it if it is affected.

What it is: CVE-2023-5564 is a medium-severity cross-site scripting vulnerability in froxlor/froxlor, published on 13 Oct 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-5564 exists.

Affected packages and fixed versions:
- froxlor/froxlor (Packagist): affected all versions; fixed in 2.1.0-dev1
- froxlor/froxlor (Packagist): affected all versions; fixed in 2.1.0-dev1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-5564/ (Markdown: https://insights.sbomify.com/CVE-2023-5564/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-5564
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-5564
- OSV: https://osv.dev/vulnerability/CVE-2023-5564

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-5564/
Summaries are generated and may contain mistakes; the official description above is the record.
