# CVE-2023-5572: Server-Side Request Forgery (SSRF) in vriteio/vrite

> An attacker can exploit a Server-Side Request Forgery vulnerability in the Vrite web application to access internal resources or bypass security controls.

- **Severity:** Critical 10.0 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Oct 2023
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-w35p-wxwj-rcm9

## What is CVE-2023-5572?

CVE-2023-5572 is a critical server-side request forgery vulnerability in vriteio/vrite, published on 13 Oct 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Server-Side Request Forgery (SSRF) in GitHub repository vriteio/vrite prior to 0.3.0.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2023-5572?

2 open source packages ship an affected version, including @vrite/sdk. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@vrite/sdk` | npm | All versions | 0.3.0 |
| `@vrite/sdk` | npm | All versions | 0.3.0 |

Products: Vrite Vrite.

## How do I fix CVE-2023-5572?

Upgrade @vrite/sdk to 0.3.0 or later.

## Is CVE-2023-5572 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-5572 exists.

## Other vulnerabilities in vriteio/vrite

- [CVE-2023-5571](https://insights.sbomify.com/CVE-2023-5571/): Improper Input Validation in vriteio/vrite (medium 6.5)
- [CVE-2023-5573](https://insights.sbomify.com/CVE-2023-5573/): Allocation of Resources Without Limits or Throttling in vriteio/vrite (medium 4.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-5572 and fix it if it is affected.

What it is: CVE-2023-5572 is a critical server-side request forgery vulnerability in vriteio/vrite, published on 13 Oct 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-5572 exists.

Affected packages and fixed versions:
- @vrite/sdk (npm): affected all versions; fixed in 0.3.0
- @vrite/sdk (npm): affected all versions; fixed in 0.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-5572/ (Markdown: https://insights.sbomify.com/CVE-2023-5572/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-5572
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-5572
- OSV: https://osv.dev/vulnerability/CVE-2023-5572

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-5572/
Summaries are generated and may contain mistakes; the official description above is the record.
