{"answers":{"affected":"2 open source packages ship an affected version, including pleroma. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-5588 in the wild and no public exploit code.","fix":"Upgrade pleroma to 2.5.3 or later.","what":"CVE-2023-5588 is a low-severity path traversal vulnerability in kphrx pleroma, published on 15 Oct 2023. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-5588 and fix it if it is affected.\n\nWhat it is: CVE-2023-5588 is a low-severity path traversal vulnerability in kphrx pleroma, published on 15 Oct 2023. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-5588 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pleroma (Hex): affected all versions; fixed in 2.5.3\n- pleroma (Hex): affected all versions; fixed in 2.5.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-5588/ (Markdown: https://insights.sbomify.com/CVE-2023-5588/index.md)","id":"CVE-2023-5588","markdown":"https://insights.sbomify.com/CVE-2023-5588/index.md","name":"CVE-2023-5588","record":{"aliases":["GHSA-2c28-m2m7-mf55"],"analysis":{"component_type":"web_application","fix_type":"patch","impacts":["data_read"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Pleroma social network","requires_auth":"low_privilege","summary":"Attackers can exploit a path traversal flaw in the emoji pack functionality to read arbitrary files from the server.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"pleroma","vendor":"kpherox"}],"cvss":{"score":2.6,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:A/AC:H/PR:L/UI:N/S:U/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"A vulnerability was found in kphrx pleroma. It has been classified as problematic. This affects the function Pleroma.Emoji.Pack of the file lib/pleroma/emoji/pack.ex. The manipulation of the argument name leads to path traversal. The complexity of an attack is rather high. The exploitability is told to be difficult. This product does not use versioning. This is why information about affected and unaffected releases are unavailable. The patch is named 2c795094535537a8607cc0d3b7f076a609636f40. It is recommended to apply a patch to fix this issue. The associated identifier of this vulnerability is VDB-242187.","ecosystems":["Hex"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"kphrx pleroma pack.ex Pleroma.Emoji.Pack path traversal","id":"CVE-2023-5588","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Hex","product":null,"products":[],"type":"path_traversal","year":"2023"},"n_packages":2,"n_references":4,"next":{"headline":"SourceCodester Judging Management System login.php sql injection","id":"CVE-2023-5589"},"packages":[{"ecosystem":"Hex","fixed":["2.5.3"],"introduced":["0"],"last_affected":[],"package":"pleroma","purl":null,"source":"GHSA-2c28-m2m7-mf55"},{"ecosystem":"Hex","fixed":["2.5.3"],"introduced":["0"],"last_affected":[],"package":"pleroma","purl":"pkg:hex/pleroma","source":"GHSA-2c28-m2m7-mf55"}],"prev":{"headline":"SourceCodester Free Hospital Management System for Small Practices Parameter doctors.php sql injection","id":"CVE-2023-5587"},"products":["pleroma"],"published":"2023-10-15","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-02","vendors":["kphrx"]},"summary":"Attackers can exploit a path traversal flaw in the emoji pack functionality to read arbitrary files from the server.","url":"https://insights.sbomify.com/CVE-2023-5588/"}