# CVE-2023-5588: kphrx pleroma pack.ex Pleroma.Emoji.Pack path traversal

> Attackers can exploit a path traversal flaw in the emoji pack functionality to read arbitrary files from the server.

- **Severity:** Low 2.6 (`CVSS:3.1/AV:A/AC:H/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Oct 2023
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-2c28-m2m7-mf55

## What is CVE-2023-5588?

CVE-2023-5588 is a low-severity path traversal vulnerability in kphrx pleroma, published on 15 Oct 2023. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A vulnerability was found in kphrx pleroma. It has been classified as problematic. This affects the function Pleroma.Emoji.Pack of the file lib/pleroma/emoji/pack.ex. The manipulation of the argument name leads to path traversal. The complexity of an attack is rather high. The exploitability is told to be difficult. This product does not use versioning. This is why information about affected and unaffected releases are unavailable. The patch is named 2c795094535537a8607cc0d3b7f076a609636f40. It is recommended to apply a patch to fix this issue. The associated identifier of this vulnerability is VDB-242187.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2023-5588?

2 open source packages ship an affected version, including pleroma. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pleroma` | Hex | All versions | 2.5.3 |
| `pleroma` | Hex | All versions | 2.5.3 |

Products: Kpherox Pleroma.

## How do I fix CVE-2023-5588?

Upgrade pleroma to 2.5.3 or later.

## Is CVE-2023-5588 being exploited?

There is no known exploitation of CVE-2023-5588 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-5588 and fix it if it is affected.

What it is: CVE-2023-5588 is a low-severity path traversal vulnerability in kphrx pleroma, published on 15 Oct 2023. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-5588 in the wild and no public exploit code.

Affected packages and fixed versions:
- pleroma (Hex): affected all versions; fixed in 2.5.3
- pleroma (Hex): affected all versions; fixed in 2.5.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-5588/ (Markdown: https://insights.sbomify.com/CVE-2023-5588/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-5588
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-5588
- OSV: https://osv.dev/vulnerability/CVE-2023-5588

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-5588/
Summaries are generated and may contain mistakes; the official description above is the record.
