# CVE-2023-5590: NULL Pointer Dereference in seleniumhq/selenium

> A null pointer dereference in Selenium allows attackers to cause a denial of service condition.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Oct 2023
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-4phc-fq33-39gx, PYSEC-2023-206

## What is CVE-2023-5590?

CVE-2023-5590 is a high-severity vulnerability in seleniumhq/selenium, published on 15 Oct 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

NULL Pointer Dereference in GitHub repository seleniumhq/selenium prior to 4.14.0.

Weakness: CWE-476 (NULL Pointer Dereference)

## Which versions are affected by CVE-2023-5590?

1 open source package ship an affected version, including selenium. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `selenium` | PyPI | All versions | 4.14.0 |

Products: Selenium Selenium.

## How do I fix CVE-2023-5590?

Upgrade selenium to 4.14.0 or later.

## Is CVE-2023-5590 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-5590 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-5590 and fix it if it is affected.

What it is: CVE-2023-5590 is a high-severity vulnerability in seleniumhq/selenium, published on 15 Oct 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-5590 exists.

Affected packages and fixed versions:
- selenium (PyPI): affected all versions; fixed in 4.14.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-5590/ (Markdown: https://insights.sbomify.com/CVE-2023-5590/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-5590
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-5590
- OSV: https://osv.dev/vulnerability/CVE-2023-5590

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-5590/
Summaries are generated and may contain mistakes; the official description above is the record.
