# CVE-2023-5591: SQL Injection in librenms/librenms

> An attacker can execute arbitrary SQL commands in LibreNMS, potentially reading or modifying database contents.

- **Severity:** High 7.8 (`CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Oct 2023
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-mr6h-7x2m-rgmq

## What is CVE-2023-5591?

CVE-2023-5591 is a high-severity SQL injection vulnerability in Librenms Librenms, published on 16 Oct 2023. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

SQL Injection in GitHub repository librenms/librenms prior to 23.10.0.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2023-5591?

2 open source packages ship an affected version, including librenms/librenms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `librenms/librenms` | Packagist | All versions | 23.10.0 |
| `librenms/librenms` | Packagist | All versions | 23.10.0 |

Products: Librenms Librenms.

## How do I fix CVE-2023-5591?

Upgrade librenms/librenms to 23.10.0 or later.

## Is CVE-2023-5591 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-5591 exists.

## Other vulnerabilities in Librenms Librenms

- [CVE-2023-4982](https://insights.sbomify.com/CVE-2023-4982/): Cross-site Scripting (XSS) - Stored in librenms/librenms (critical 9.8)
- [CVE-2022-29712](https://insights.sbomify.com/CVE-2022-29712/): Command injection in librenms (critical 9.8)
- [CVE-2021-44278](https://insights.sbomify.com/CVE-2021-44278/): Path traversal in librenms/librenms (critical 9.8)
- [CVE-2019-10665](https://insights.sbomify.com/CVE-2019-10665/): LibreNMS Information Disclosure (critical 9.8)
- [CVE-2018-20434](https://insights.sbomify.com/CVE-2018-20434/): LibreNMS arbitrary OS commands execution (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-5591 and fix it if it is affected.

What it is: CVE-2023-5591 is a high-severity SQL injection vulnerability in Librenms Librenms, published on 16 Oct 2023. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-5591 exists.

Affected packages and fixed versions:
- librenms/librenms (Packagist): affected all versions; fixed in 23.10.0
- librenms/librenms (Packagist): affected all versions; fixed in 23.10.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-5591/ (Markdown: https://insights.sbomify.com/CVE-2023-5591/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-5591
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-5591
- OSV: https://osv.dev/vulnerability/CVE-2023-5591

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-5591/
Summaries are generated and may contain mistakes; the official description above is the record.
