CVE-2023-5600 Missing Authorization in GitLab

Low 3.1 Published Updated

Attackers can leak private reference titles via service-desk email templates in GitLab EE, requiring an upgrade to secure data.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-5600?

CVE-2023-5600 is a low-severity missing authorization vulnerability in Gitlab Gitlab, published on 20 Jun 2025. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

An issue has been discovered in GitLab EE affecting all versions starting from 16.0 before 16.3.6, all versions starting from 16.4 before 16.4.2, all versions starting from 16.5 before 16.5.1. Arbitrary access to the titles of an private specific references could be leaked through the service-desk custom email template.

Weakness: CWE-862

Which versions are affected by CVE-2023-5600?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 16.0.016.3.6, 16.4.2, 16.5.1

Products include Gitlab Gitlab.

How do I fix CVE-2023-5600?

Upgrade gitlab to a fixed version for your release line: 16.3.6, 16.4.2 or 16.5.1.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2023-5600 being exploited?

There is no known exploitation of CVE-2023-5600 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2023-5600, GHSA-h62c-3g8w-9vjr.

Is CVE-2023-5600 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free