CVE-2023-5631 Roundcube Webmail Persistent Cross-Site Scripting (XSS)
Remote attackers can execute arbitrary JavaScript in victim browsers via crafted SVG emails, potentially leading to account takeover.
- Exploited in the wild
- Since 26 Oct 2023
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2023-5631?
CVE-2023-5631 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 18 Oct 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Roundcube before 1.4.15, 1.5.x before 1.5.5, and 1.6.x before 1.6.4 allows stored XSS via an HTML e-mail message with a crafted SVG document because of program/lib/Roundcube/rcube_washtml.php behavior. This could allow a remote attacker
to load arbitrary JavaScript code.
Weakness: CWE-79
Which versions are affected by CVE-2023-5631?
1 open source package ship an affected version, including roundcube. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
roundcube Bitnami | All versions | 1.4.15, 1.5.5, 1.6.4 |
Linux distribution packages (3)
roundcubemail SUSE:Package Hub 15 SP5 | All versions | 1.6.4-bp155.2.6.1 |
roundcubemail openSUSE:Leap 15.5 | All versions | 1.6.4-bp155.2.6.1 |
roundcubemail openSUSE:Tumbleweed | All versions | 1.6.4-1.1 |
Products include Debian Debian Linux, Fedoraproject Fedora, Roundcube Webmail.
How do I fix CVE-2023-5631?
Upgrade roundcube to a fixed version for your release line: 1.4.15, 1.5.5 or 1.6.4. US federal agencies must fix it by 16 Nov 2023.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2023-5631 being exploited?
Yes. Attackers have exploited CVE-2023-5631 in the wild since at least 26 Oct 2023.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as BIT-roundcube-2023-5631, CVE-2023-46267, DEBIAN-CVE-2023-5631, DLA-3630-1, DSA-5531-1, GHSA-qf8f-27cp-gw76 and 3 more.