# CVE-2023-5631: Roundcube Webmail Persistent Cross-Site Scripting (XSS)

> Remote attackers can execute arbitrary JavaScript in victim browsers via crafted SVG emails, potentially leading to account takeover.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Yes, since 26 Oct 2023 (CISA KEV)
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 18 Oct 2023
- **Updated:** 21 Oct 2025
- **Also known as:** BIT-roundcube-2023-5631, CVE-2023-46267, DEBIAN-CVE-2023-5631, DLA-3630-1, DSA-5531-1, GHSA-qf8f-27cp-gw76, UBUNTU-CVE-2023-5631, openSUSE-SU-2023:0345-1, openSUSE-SU-2024:13365-1

## What is CVE-2023-5631?

CVE-2023-5631 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 18 Oct 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Roundcube before 1.4.15, 1.5.x before 1.5.5, and 1.6.x before 1.6.4 allows stored XSS via an HTML e-mail message with a crafted SVG document because of program/lib/Roundcube/rcube_washtml.php behavior. This could allow a remote attacker

to load arbitrary JavaScript code.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2023-5631?

1 open source package ship an affected version, including roundcube. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `roundcube` | Bitnami | All versions | 1.4.15, 1.5.5, 1.6.4 |
| `roundcubemail` | SUSE:Package Hub 15 SP5 | All versions | 1.6.4-bp155.2.6.1 |
| `roundcubemail` | openSUSE:Leap 15.5 | All versions | 1.6.4-bp155.2.6.1 |
| `roundcubemail` | openSUSE:Tumbleweed | All versions | 1.6.4-1.1 |

Products: Debian Debian Linux, Fedoraproject Fedora, Roundcube Webmail.

## How do I fix CVE-2023-5631?

Upgrade roundcube to a fixed version for your release line: 1.4.15, 1.5.5 or 1.6.4. US federal agencies must fix it by 16 Nov 2023.

## Is CVE-2023-5631 being exploited?

Yes. Attackers have exploited CVE-2023-5631 in the wild since at least 26 Oct 2023.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-5631 and fix it if it is affected.

What it is: CVE-2023-5631 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 18 Oct 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: Yes. Attackers have exploited CVE-2023-5631 in the wild since at least 26 Oct 2023.

Affected packages and fixed versions:
- roundcube (Bitnami): affected all versions; fixed in 1.4.15, 1.5.5, 1.6.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-5631/ (Markdown: https://insights.sbomify.com/CVE-2023-5631/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-5631
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-5631
- OSV: https://osv.dev/vulnerability/CVE-2023-5631

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-5631/
Summaries are generated and may contain mistakes; the official description above is the record.
