# CVE-2023-5632: Unconditionally adding an event to the epoll causes excessive CPU consumption

> An attacker can cause excessive CPU consumption and denial of service in Eclipse Mosquitto by establishing connections without sending data.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Oct 2023
- **Updated:** 13 Sep 2024
- **Also known as:** DEBIAN-CVE-2023-5632, GHSA-4jhw-x435-x5f7

## What is CVE-2023-5632?

CVE-2023-5632 is a high-severity denial of service vulnerability in Eclipse Mosquitto, published on 18 Oct 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Eclipse Mosquito before and including 2.0.5, establishing a connection to the mosquitto server without sending data causes the EPOLLOUT event to be added, which results excessive CPU consumption. This could be used by a malicious actor to perform denial of service type attack. This issue is fixed in 2.0.6

Weakness: CWE-834 (Excessive Iteration)

## Which versions are affected by CVE-2023-5632?

It affects 1 product.


Products: Eclipse Mosquitto.

## How do I fix CVE-2023-5632?

Upgrade to a fixed version.

## Is CVE-2023-5632 being exploited?

There is no known exploitation of CVE-2023-5632 in the wild and no public exploit code.

## Other vulnerabilities in Eclipse Mosquitto

- [CVE-2018-12550](https://insights.sbomify.com/CVE-2018-12550/): Auth bypass in Eclipse Mosquitto (high 8.1)
- [CVE-2018-12551](https://insights.sbomify.com/CVE-2018-12551/): Auth bypass in Eclipse Mosquitto (high 8.1)
- [CVE-2023-28366](https://insights.sbomify.com/CVE-2023-28366/): Denial of service in n/a (high 7.5)
- [CVE-2021-41039](https://insights.sbomify.com/CVE-2021-41039/): Denial of service in Eclipse Mosquitto (high 7.5)
- [CVE-2021-34432](https://insights.sbomify.com/CVE-2021-34432/): Denial of service in Eclipse Mosquitto (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-5632 and fix it if it is affected.

What it is: CVE-2023-5632 is a high-severity denial of service vulnerability in Eclipse Mosquitto, published on 18 Oct 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-5632 in the wild and no public exploit code.

Affected product: Eclipse Mosquitto. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-5632/ (Markdown: https://insights.sbomify.com/CVE-2023-5632/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-5632
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-5632
- OSV: https://osv.dev/vulnerability/CVE-2023-5632

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-5632/
Summaries are generated and may contain mistakes; the official description above is the record.
