# CVE-2023-5654: React Developer Tools extension Improper Authorization vulnerability

> A malicious webpage can force the React Developer Tools extension to fetch arbitrary URLs, enabling Server-Side Request Forgery attacks via the victim's browser.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Oct 2023
- **Updated:** 12 Sep 2024
- **Also known as:** GHSA-rxrc-rgv4-jpvx

## What is CVE-2023-5654?

CVE-2023-5654 is a medium-severity server-side request forgery vulnerability in Meta React Developer Tools Extension, published on 19 Oct 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The React Developer Tools extension registers a message listener with window.addEventListener('message', <listener>) in a content script that is accessible to any webpage that is active in the browser. Within the listener is code that requests a URL derived from the received message via fetch(). The URL is not validated or sanitised before it is fetched, thus allowing a malicious web page to arbitrarily fetch URL’s via the victim's browser.

Weakness: CWE-116 (Improper Encoding or Escaping of Output), CWE-285 (Improper Authorization)

## Which versions are affected by CVE-2023-5654?

2 open source packages ship an affected version, including react-devtools-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `react-devtools-core` | npm | All versions | 4.28.4 |
| `react-devtools-core` | npm | All versions | 4.28.4 |

Products: Facebook React-Devtools.

## How do I fix CVE-2023-5654?

Upgrade react-devtools-core to 4.28.4 or later.

## Is CVE-2023-5654 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-5654 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-5654 and fix it if it is affected.

What it is: CVE-2023-5654 is a medium-severity server-side request forgery vulnerability in Meta React Developer Tools Extension, published on 19 Oct 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-5654 exists.

Affected packages and fixed versions:
- react-devtools-core (npm): affected all versions; fixed in 4.28.4
- react-devtools-core (npm): affected all versions; fixed in 4.28.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-5654/ (Markdown: https://insights.sbomify.com/CVE-2023-5654/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-5654
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-5654
- OSV: https://osv.dev/vulnerability/CVE-2023-5654

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-5654/
Summaries are generated and may contain mistakes; the official description above is the record.
