CVE-2023-5664 Garden Gnome Package <= 2.2.8 - Authenticated (Contributor+) Stored Cross-Site Scripting via Shortcode

Medium 6.4 Published Updated

Authenticated attackers can inject arbitrary scripts via shortcode, leading to script execution in victim browsers.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2023-5664?

CVE-2023-5664 is a medium-severity cross-site scripting vulnerability in ggnomes Garden Gnome Package, published on 22 Nov 2023. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

The Garden Gnome Package plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'ggpkg' shortcode in all versions up to, and including, 2.2.8 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers with contributor-level and above permissions to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This was partially patched in version 2.2.7 and fully patched in version 2.2.9.

Weakness: CWE-79

Which versions are affected by CVE-2023-5664?

It affects 1 product.

Products include Ggnome Garden Gnome Package.

How do I fix CVE-2023-5664?

No fix has been published for CVE-2023-5664 yet. Limit exposure of the affected software until one is available.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2023-5664 being exploited?

There is no known exploitation of CVE-2023-5664 in the wild and no public exploit code.

Sources

Also known as GHSA-3cxp-wr2c-p97q.

Is CVE-2023-5664 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free