# CVE-2023-5685: Xnio: stackoverflowexception when the chain of notifier states becomes problematically big

> An attacker can cause a denial of service by triggering a stack overflow in the XNIO library through large notifier state chains.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Mar 2024
- **Updated:** 14 Sep 2026
- **Also known as:** CLSA-2026-1771978226, CLSA-2026-1780620672, DEBIAN-CVE-2023-5685, GHSA-7f88-5hhx-67m2, UBUNTU-CVE-2023-5685

## What is CVE-2023-5685?

CVE-2023-5685 is a high-severity denial of service vulnerability in Red Hat Build of Keycloak, published on 22 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A flaw was found in XNIO. The XNIO NotifierState that can cause a Stack Overflow Exception when the chain of notifier states becomes problematically large can lead to uncontrolled resource management and a possible denial of service (DoS).

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2023-5685?

2 open source packages ship an affected version, including org.jboss.xnio:xnio-api.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jboss.xnio:xnio-api` | Maven | All versions | 3.8.14.Final |
| `org.jboss.xnio:xnio-api` | Maven | All versions | 3.8.14.Final |

## How do I fix CVE-2023-5685?

Upgrade org.jboss.xnio:xnio-api to 3.8.14.Final or later.

## Is CVE-2023-5685 being exploited?

There is no known exploitation of CVE-2023-5685 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-5685 and fix it if it is affected.

What it is: CVE-2023-5685 is a high-severity denial of service vulnerability in Red Hat Build of Keycloak, published on 22 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-5685 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jboss.xnio:xnio-api (Maven): affected all versions; fixed in 3.8.14.Final
- org.jboss.xnio:xnio-api (Maven): affected all versions; fixed in 3.8.14.Final

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-5685/ (Markdown: https://insights.sbomify.com/CVE-2023-5685/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-5685
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-5685
- OSV: https://osv.dev/vulnerability/CVE-2023-5685

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-5685/
Summaries are generated and may contain mistakes; the official description above is the record.
