CVE-2023-5692 WordPress Core <= 6.4.3 - Sensitive Information Exposure via redirect_guess_404_permalink

Medium 5.3 Published Updated

Unauthenticated attackers can expose slugs of custom posts with non-public statuses via a redirect function in WordPress Core.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-5692?

CVE-2023-5692 is a medium-severity vulnerability in WordPress, published on 5 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

WordPress Core is vulnerable to Sensitive Information Exposure in versions up to, and including, 6.4.3 via the redirect_guess_404_permalink function. This can allow unauthenticated attackers to expose the slug of a custom post whose 'publicly_queryable' post status has been set to 'false'.

Weakness: CWE-200

Which versions are affected by CVE-2023-5692?

2 open source packages ship an affected version, including wordpress and wordpress-multisite.

PackageAffectedFixed in
wordpress BitnamiAll versions6.5.0
wordpress-multisite BitnamiAll versions6.5.0

How do I fix CVE-2023-5692?

Upgrade wordpress to 6.5.0 or later.

Is CVE-2023-5692 being exploited?

There is no known exploitation of CVE-2023-5692 in the wild and no public exploit code.

Sources

Also known as BIT-wordpress-2023-5692, BIT-wordpress-multisite-2023-5692, DEBIAN-CVE-2023-5692, GHSA-9m7w-p6hr-xv2x, UBUNTU-CVE-2023-5692.

Is CVE-2023-5692 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free